RFXcom scenes unreliable / not working

I’ve been using some klik-aan-klik-uit sockets for quite some time. They’ve always worked with my RFXcom transceiver. They still do.

Last week I began to convert some of my older scenes into the new scenes in HA that are configurable through the UI. Very nice. :slight_smile:

I have 2 livingroom-lights, light.kaku01 and light.kaku02, they’re in a group called light.livingroom_lights. I configured that group with the helper UI.
When I add either the separate entities or the group to a scene they will not work.

What I’ve tried:

  1. If I add the group or the entities to an automation and turn then on / off through there it works.
  2. If I manually run the scene it works. (The other lights from that scene are already on/off)
  3. If I manually turn the separate entities on it works.
  4. The scene where I turn every light I have off, does work. Even for these troublemakers.

I wanted to test with the option to repeat the signal twice, but that options is not longer present in the integration configuration.

I don’t think there’s anything wrong with the RFXcom intergration. But something is not working right when those lights.xxxx are added to a scene. (Either as a group or separately.)

Any idea what’s going on?