RFXcom without transmitter

Hi all,

I have just received my RFXcom transmitter / receiver. I want to use this with my Novy hood.
When I send commands from RFXmanager it works fine, however I can’t seem to receive them from the remote.

Unfortunately for RFXtrx switches to be added to Home Assistant, you have to be able to receive them first. Does anyone have a way to add them just based on the output of RFXmanager?


1 Like

Hi @thomas-be,

Would you be able to share your configuration files, so it can be verified? :slight_smile:

What I have in my config is

  device: /dev/ttyUSB0
  platform: rfxtrx
  automatic_add: true

The config works as it automagically adds “dumb” 433MHZ switches which appear with their proper ID. However, the RFXtrx does not recognise the Novy commands (not even in RFXmngr) so I cannot add them. So the problem is not my config but the fact that the Novy protocol is not properly recognised by RFXtrx; i am in contact with them about the issue, but I understand it may take them a while to fix it.

Meanwhile, a solution would be that someone who may have gotten it to work can send me the ID’s for the switches as they have them. That way i can manually add them. For example:

  platform: rfxtrx
    0b11000102ef9f210010f70:   //<-- This is what I am looking for! (example value, not the one for Novy)
      name: hood_plus

Hello thomas-be,

I also want to control my Novy extractor hood with HA.

What RFXcom receiver / transmitter do you have?

Mine is the RFXtrx433E

I just installed version 1042 of the firmware of my RFXtrx433E.

The RFXmngr application works and the FAN commands to the Novy extractor hood (via the Novy remote control) work.
The LEDs on the RFXtrx433E operate each time the “Transmit” button on the RFXmngr is pressed.
Pressing the Novy remote control acts on the LEDs of the RFXmngr if you check in the “Main” tab the “Undec on” box.

The problem is that the RFXtrx433E does not keep the “undec on” parameter when it is disconnected and reconnected to RFXmngr.

The “save setting” button does not save the parameters in the RFXtrx433E once the latter is disconnected from the RFXmngr.

This means that HA will never be able to pair the Novy remote control.

The “undec on” box should be checked at startup like the other boxes in RFXmngr

Have you made progress on the code to put in HA?

Hello everyone,

apparently, those who have an RFXtrx433E like me, cannot pair in HA the Novy remote control (delivered with the hood). Because the RFXtrx433E does not receive the Novy code from the Novy remote control.

On the other hand those who have an RFXtrx433XL, can pair in HA the Novy remote control (delivered with the hood).
For those who did, could you send us the code to enter in HA to operate our Novy hood?

Thanks in advance

In fact, this is not entirely true. I do have the XL, but it does not recognise the commands from my remote. It does receive them in raw mode, but they don’t get decoded and thus Home Asssitant does not create the switch.

I have contacted RFXCom about this and sent them my raw codes, but apparently they have not had the time yet to fix this.

But I also hope that someone got it to work so we can get the config from them.


I don’t know if RFXCom can do something or not but : Novy remote control in HA using RFXTRX?

I also contacted them and there seems to be a timing issue or something with the remote commands so they are not recognised by the rfxtrx device.

I do have the XL version and I can receive the signal in Raw mode, only the rfxtrx does not recognise it as novy.


Continuing the discussion here: Novy remote control in HA using RFXTRX?