RFXtrx entity ID after 0.113 upgrade

I have a Telldus outdoor switch that used to have entity ID like 0b11000685bc0cfe05010f70 but after upgrading hassio it has changed (i think). I have one rfxtrx433e connected to my hassio machine. I do NOT have any telldus stick. The telldus remote is also gone so I can not trigger the device. My problem is how to get the new entity ID of my Telldus switch. Is it possible to “convert” between the old ID and the new?

Regards Perssola

How did you come to the conclusion the ID changed?

After upgrading my 0.112 hassio every Rfxtrx device changed.
This wont work anymore:

- platform: rfxtrx
  automatic_add: true
  signal_repetitions: 2
      name: carheater

My question is how to get my Telldus (carheater) to work again?

I have exactly the same problem,
I have been outside for a job for 6 months, HA 0.111 With HassOS was running fine, my wife used this all days.
Now iám back @home.
Made a snapshot in ESXI first ( I’am still running as test)
First update to HassOS 4.16 => OK
The Update 0.111 to 0.117 =Fail could not run anything, so i put back the snapshot.
Left it for a week.

Yesterday is updated again to 0.118.3 since this was the newest.
It took about 45 minutes to conevert but running ok now

Only 1 thing with problems

RFXtrx is running ok

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1WP593Q-if00-port0

My push buttons where easily found
But all my lights are not working, they are commented out the configuration.yaml
I uncommented them all but still no luck

  platform: rfxtrx
  automatic_add: true

      name: Lichtknop
      #fire_event: true
      name: DeurTafel
      name: Deurbel
      fire_event: true
      name: LampTV
      name: Arc02
      name: Arc03
      name: LampSerre
      name: LampPeter
      name: SchemerRaam

So how do i add them to the RFXtrx device ?
( i do not have remote’s here, the most push buttons are zigbee inwall types)

Ok after searching websites i found a solution
add manually Rfxtrx Options

Now i have to find a solution to change the device from
 switch.ac_1010104_1   to Light

I found that i should change the last digit, but that seems not work for now, i have ARC sensor
for ARC sensors it should be 01 0F70 -> 02 0F70
for LIghtwaveRF it should be: 01 0F70 -> 10 0F70

Have you looked at the integration in the UI? The configuration of RFXtrx has moved into the UI. The first step of the change may have been in 0.113 (can’t remember exactly)

That’s when the config of devices moved under rfxtrx - instead of something like:

  platform: rfxtrx

It went under rfxtrx:

  device: /dev/rfxtrx

Then in 0.117 the rest of the config moved into the UI. It has probably imported your current config, but changes will now need to be made in the UI rather than the YAML files.

What hell,

0710011443020100 Should be light and not switch, why is this made so difficulty ??
In my old 0.111 in configuration.yaml

   name: LampSerre

Now in the new 0.118.3 add with the rfxtrx integration
Shown as a switch with uninteresting things like receive power and a binary switch
I only want Light.LampSerre and not use something like switch.ac_1010101_1

Update, it is working but not in a smart automated method
First i add the 0B11000F0101010101010000 in the rtfx_trx

Then in my automation yaml and my lovelace card
There is something strange, the capital letter are not accepted?

Strange that the other switch light " Bij TV" only works with switch.arc_c2 in the card , light.lamptv is not accepted

Maybe i do something wrong, but what i would like to have that i can set an alias name once in the rfxtrx integration page and use this alias name every where so that there is no need to do this in configuration .yaml.