RFXtrx - How to configure from RFXmngr

Hi !
I follow many topics in the forum to understand how to implement my RFXtrx433e. As a new configuration way was implemented in last versions of HASS now it’s very difficult to configure because no tutorial on the topic. I’m coming from opeHAB and this part is very difficult to understand in my side…

So in my case I use Home Assistant 0.114.4 on raspberry 3.
I have a doorbell. So I need to SEND message from HASS via my RFXcom to my doorbell.
I follow this documentation without any success : https://www.home-assistant.io/integrations/rfxtrx/#generate-codes
I use RFXmngr, I have this result when I contact my doorbell :

As you can see my id is = 1000000 and decimal : 16777216

This is my configuration :

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A14MNU4-if00-port0
    # Carillon
    0b11000395bc0cfe06010f70: # this id as been generated with this link https://www.home-assistant.io/integrations/rfxtrx/#generate-codes

When I read the documentation it expalin we can generate an id but mine are not like that and I don’t know how to translate my decimal + unit into the Home Assistant needs.
My 'learn" on doorbell is done on RFXmngr and works well…

Please help me Thanks a lot !

I’m confused with this statement. If it’s a doorbell, you’d want HA to know when someone presses the doorbell right? In which case it would be a sensor in HA with data coming from the Doorbell to the RFX to HA?
If so why not try automatic_add in your config so it shows up automatically?
You can then catch the ID and add it to your config.
You’ll probably need to add fire_event: true to the device definition as the entity’s state may not change (if it’s like the one I used to have)…
The other way round would be to set your logging to debug for the RFX to catch everything that passes through the RFX:

  default: error
    homeassistant.components.rfxtrx: debug
  1. Thanks a lot for your help. Your idea to trace more precisely the issue in log rfx is a good idea :wink:
  2. Sorry for my confusion : I have a sensor (in Zwave technology) . When it detect a movement I want to activate my bell. For that I need to SEND the information to my bell to play the sound.
  3. That’s why catching in log the ID is not possible beacause not activate… So My only solution is to use the RFXmngr (cf my screenshot). But I don’t know how to convert this ID to HASS.
  4. automatic_add dosn’t work because my bell is waiting for a message to play and not PUSHING a message… : in this way how to catch my ID for HASS ?

In automatic detection HASS find a temperature sensor :

2020-09-09 14:05:49 INFO (MainThread) [homeassistant.components.rfxtrx.sensor] Added sensor (Device ID: c9:01 Class: RFXtrxDevice Sub: 3, Event: 0a520300c90100f20f0249)
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx] Receive RFXCOM event: {'packet_type': 82, 'sub_type': 3, 'type_string': 'RTGR328', 'id_string': 'c9:01', 'data': '0a520301c90100f20f0249', 'values': {'Temperature': 24.2, 'Humidity': 15, 'Humidity status': 'normal', 'Humidity status numeric': 2, 'Battery numeric': 9, 'Rssi numeric': 4}}
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx.sensor] Sensor update (Device ID: c9:01 Class: RFXtrxDevice Sub: 3)
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx.sensor] Sensor update (Device ID: c9:01 Class: RFXtrxDevice Sub: 3)
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx.sensor] Sensor update (Device ID: c9:01 Class: RFXtrxDevice Sub: 3)
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx.sensor] Sensor update (Device ID: c9:01 Class: RFXtrxDevice Sub: 3)
2020-09-09 14:06:42 DEBUG (MainThread) [homeassistant.components.rfxtrx.sensor] Sensor update (Device ID: c9:01 Class: RFXtrxDevice Sub: 3)

But of course not my bell…
This is the link to my device :
It works in openHAB but I don’t understand how to implement it in HASS.

Hope I’m clear. And again, thanks a lot for your help.

ok, then in that case you need to pair the bell.
The easiest would be to create a switch and use some “random” ID in HA, set the bell in pairing mode, then issue an on command (turn the switch on)

Unfortunately this method is not good now. Since last version of this module we can’t define the type of objects…

So I tried this formules :
0a14000{{ range(100,700) | random | int }}bc0cf{{ range(0,10) | random | int }}100f70 +
0b11000{{ range(100,700) | random | int }}bc0cfe0{{ range(0,10) | random | int }}020f70 +
0b11000{{ range(100,700) | random | int }}bc0cfe0{{ range(0,10) | random | int }}010f70
and restart (each time)

  • this automation :
- id: '1599078015618'
  alias: Passage_Garage
  description: Date Passage Garage
  - entity_id: binary_sensor.fgms001_zw5_motion_sensor_home_security_motion_detected
    from: 'off'
    platform: state
    to: 'on'
  condition: []
  - service: python_script.set_now
      entity_id: input_text.date_passage_garage
      state: ok 
  - service: rfxtrx.send
      event: 0b11000451bc0cfe09010f70 # For exemple

and push in lear mode before doing the action… nothing appear in the log :frowning:

Maybe it’s because my component is an AC type…

you need the formula to define an ID.
You then need to save that ID as the one that will get assigned to your device.
you use this ID to define a switch in the config
you restart HA, set the device in pairing mode, then turn the switch on in HA to complete the pairing (needs to be done immediately after setting the device in pairing mode
Based on above example, your config should look like the one you originally posted:

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A14MNU4-if00-port0
    # Carillon

You should see this switch created after restarting HA
To switch it on, either use the auto-generated switch in your lovelace view (depending on how you manage your lovelace view) or use the Developer Tool Tab > Services:

Your description is very precise. Thanks a lot.
But my main issue is that ID described in my configuration.yaml never come in HA after a restart
I have defined it in the config like that :

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A14MNU4-if00-port0
  automatic_add: true
    # Carillon
      fire_event: true
    # RTGR328
    # PT2262
    # PT2262

But after the restart I push my bell learn mode and try to find my ID 0b11000395bc0cfe06010f70
But nothing…

Looks like the ID not good ?

it could be the ID is not right indeed. It is maybe listed as a light instead, or a sensor?
Maybe try a different format, not sure if you can pick from lightning2 type of IDs online.
If not feel free to try some of my switches ID:

Thanks a lot for your time to help me I very appreciate !

But infortunatly no one works. The key is the screen I’ve posted :
Type : AS Lighting2 id is = 1000000 and decimal : 16777216 and Unit 1
If there is a way to interpret this in HASS, it will work…

[As I said, I’m coming from openHAB, I don’t understand why this module works like that, why it’s not from references defined in RFXmngr : IDs are easy to use and valided etc…
Here I have a bell and I have to guess what is the codification : impossible to catch anything because nothing arrive in the logs and in HASS.
I’m desappointed… even if HASS is a very good home automation]

No worries.
One thing I’m tring to get my head round.
That screenshot from RFXManager you sent, how do you send the command to the RFX to get that displayed? I’m guessing this is done from OpenHAB? If so OpenHAB would have your bell’s ID saved to be able to send a command to it. See if you can retrieve it from there.
I have never used OpenHAB so no idea where it is though, but on the basis that your bell is a receiving device and not a sending one, you would have at sometime done the pairing with OpenHAB…

Ok… Ok… Ok…
After your good remarks I take time again to generate the association via RFXmngr and… it dosn’t work…
I didn’t understand anything because before it was working…
After many many tests in fact, I read the documentation again of the product and discover that the product has a limitation in number of associations. Means, the receptor has a limit of 4 codes max…
So in fact after purge the memory of the product and use : 0B11000901488ECA01040F60 the association works well !
@lolouk44 So thanks so much for your help :slight_smile: And for all people using COCO Doorbell now you know what sequence to use :wink: and how to proceeed to referent devices with SENDING …

I wanted to close this topic BUT in fact my main question is not finaly resolved.
HOW to find the sequence to push into the configuration.yaml ?
AC seems start with 0B110009xxx
ARC : 0b11000xxx
Lightwave RF : 0a14000xxx

and for the others ???
I think something is missing (a tool, an help in the documentation…).
Doing a link with RFXmngr is so difficult with HASS. Again why not propose the pairing already done via RFXmngr… and the IDs…

Glad you got it working.
when it comes to sensors, HA receives the ID.
When it comes to switches, HA needs to send something. The pairing is not in fact done at the RFX hub level but at the application and device level, (anybody correct me if I’m wrong).
Each device has a slightly different format, the doc tries to provide some of the patterns but it’s difficult to keep track of all possible formats…

I did not follow the whole thread but additional info for whom may be interested.
I had similar challenges with a cheap (1,42eur) RF mini-switch. It would pair fine with multiple rf-remote but zilch from RFX even though the button was fully visible in HA. I then started from the RFX, trying to generate a signal that would allow to pair and used this to generate the ID
(GitHub - Sennevds/RFXcomIdGenerator: Generate RFXcom ID for Home Assistant). Even though limited to few rfx groups…I got a code that worked in the end…