RFXTRX not working on Rpi 4

Hi, I just installed a new raspberry pi 4 to move my homeassistant config that was running on a Rpi3B+.
I installed the hassio needed for the rpi 4 and restored my config and add ons from my latest snapshot.
But after a reboot I can’t switch on anything behind this rfxcom. Even my P1 smartmeter does’t work anymore. Put back my old rpi3 and all is working again.
Any idea’s??

How did you install hassio ?

dowloaded from HA site and installed with balena etcher

If it is the HassOS/Hassio combo it is not the modemmanager that is interfering. Did you check the port for your RFXTRX is still the same on the RbPi 4 ?

I used the same port as on my rpi 3. I also have a zigbee stick installed and that is working fine.

FYI… I have two rfxtrx, one on pi3B+ and one on Pi4… The ports are different for me (HA is running in a virtual environment on both raspberry Pi, I am not using Hassio):

device: /dev/ttyUSB0
device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433XL_DO3GSUS0-if00-port0

1 Like

Yes changing the device solved the problem.
So with RPi4 ttyUSB0 no longer works for rfxcom device.