RFXTRX only seeing one switch

I have a setup with an rfxcom, that always performed flawlessly.
About a week ago, around the time I upgraded to Homeassistant 0.53, the klik-aan/klik-uit switch that I use as a frontdoor sensor stopped reporting. Other functions, like monitoring the tempeerature and control of my blinds worked fine.

I rebooted my hass, and the doorswitch worked exactly once.

I dug out an old Kaku remote, and started playing with that, after turning on the automatic_add for all switches and sensors using rfxtrx. Hass will detect exactly one switch control then ignore the rest.

Anybody got any ideas ? Currently on 0.53.1

Hi @timt,

I’m still on 0.53.0 so not sure if there’s an issue with the .1 release, my RFXTrx works flawlessly.
Have you tried to set your rfx in debug mode to see whether you receive anything at all?

# Logging level
  default: error
    homeassistant.components.rfxtrx: debug

Hi @lolouk44,

Thanks for your suggestion, and sorry for the slow response, I was travelling.

I managed to solve the problem yesterday, by a combination of three things:

  • I attached the rfxcom to a windows laptop and ran rfx manager. That showed signals being received from a temp sensor and a remote switch, multiple times… so the RFXcom was OK. No doorswitch, but that came back after I replaced the battery
  • I then flashed new firmware to the rfxcom
  • FInally I plugged it back into the raspberry PI I’m using for HA, but I used a different USB port

Now everything works fine again. Debug logging (thanks for reminding me of that!) shows switches being detected

I guess I may have a bad USB port on the raspberry PI

Glad you found out what the issue was and it’s all back up and running