Rfxtrx platform could not be set up (ubuntu server) and z-wave don't work

Yesterday I discovered that my z-wave did not work. so I rebooted my Home-Assistant (hass.io) server.
The server is a Ubuntu Server running on top of ESXi. And the USB interfaces are connected to a PCI-e USB3 card that are passed trough the VM. This have worked perfect a long time.

That did not work, but i got this error message:


configuration.yaml are as before:

  usb_path: /dev/ttyACM0
  network_key: !secret zwave_network_key

  device: /dev/ttyUSB0

So I have tried to reboot the ESXI host server, and also re-stick the two connected USB devices, RFXtrx443E and UZB1. Same problem

lsusb command in ubuntu give me this result:

flemmingss@Home-Assistant:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 011: ID 0658:0200 Sigma Designs, Inc.
Bus 003 Device 012: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Sigma Designs are UZB1 (Z-wave), and I think Future Technology Devices International are the RFXtrx443E (rfxtrx).

What can I do here? :astonished:

is it possible that your devices are on a different USB port?
I think
I’ve set a symlink for my RfxTrx so that no matter which USB port I use, it’s always recognized:

My config now looks like this:

  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1XETWB5-if00-port0

Well, home from work, rebooted the VM and it works …
Anyway, I might do that.

1 Like