Rfxtrx stoped working overnight - usb path not available?

rfxtrx stoped working, all my switches are gone!

worked for 6 months, stopped working from one day to the other. didn’t even update manually.

i have not changed ANYTHING (not even the slightest) so it cannot be a config issue with hass.io

rfxtrx module cannot be initialized because

FileNotFoundError: [Errno 2] No such file or directory: '/dev/ttyACM0'

with terminal and hassio hardware info i found that its not ttyACM0 anymore but ttyUSB0, when i try it with this i get this stacktrace;

Error during setup of component rfxtrx
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/setup.py", line 148, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/rfxtrx.py", line 101, in setup
    rfx_object = rfxtrxmod.Connect(device, None, debug=debug)
  File "/usr/local/lib/python3.6/site-packages/RFXtrx/__init__.py", line 718, in __init__
    self.transport = transport_protocol(device, debug)
  File "/usr/local/lib/python3.6/site-packages/RFXtrx/__init__.py", line 601, in __init__
  File "/usr/local/lib/python3.6/site-packages/RFXtrx/__init__.py", line 606, in connect
    self.serial = serial.Serial(self.port, 38400, timeout=0.1)
  File "/usr/local/lib/python3.6/site-packages/serial/serialutil.py", line 182, in __init__
  File "/usr/local/lib/python3.6/site-packages/serial/serialposix.py", line 265, in open
  File "/usr/local/lib/python3.6/site-packages/serial/serialposix.py", line 595, in _update_dtr_state
    fcntl.ioctl(self.fd, TIOCMBIS, TIOCM_DTR_str)
OSError: [Errno 5] I/O error

no light switching for me ):
anything i could fix here? what happend there?

stupid question, have you tried to reboot your RPi?
What does your config show for rfxtrx:?

Not a stupid question… sadly…

I did restart multiple times through the UI, but never actually disconnected the power and reconnected…

I feel very stupid now.
After your post i did, and it worked!

Thanks, sorry for the post!

He he no worries. A restart through the ui will only restart ha. You’re issue was hardware related. It’s a good idea to plan a computer restart about once a month to avoid issues like the ones you just experienced