RFXtrx433E : folder "/dev/serial/by-id" not created

Hello everyone,
here I have a component RFXtrx433E that I can not operate with HA. I followed the tutorial https://www.home-assistant.io/components/rfxtrx/ by putting in my file:

device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A12IS2F4-if00-port0
debug: True

and as a sensor:


  • platform: rfxtrx
    automatic_add: True

I have a notification that says: The following components and platform have not been configured: rfxtrx and rfxtrx.sensor.
For me everything is good in the configuration.yaml file

How do I see if my RFXtrx works on HA?

The problem is I do not have the folder /dev/serial/by-id/ on my RPI3B where Ha is installed !!!

How come I do not have this folder created?

Are you using hassio or some other installation method?

Thank you for your reply. In fact, the directory / dev / serial / by-id / does not exist. I use hassio or krusader (on a RPI3B). The directorie / dev / exists. What I did: I put device: / dev / ttyUSB0 and it worked.
On the other hand in the tutorial https://www.home-assistant.io/components/rfxtrx/, we always speak about / dev / serial / by-id / usb-RFXCOM_RFXtrx433_A12IS2F4-if00-port0 whereas / serial / by-id / does not exist in / dev /.
The case on my side is resolved. Thanks again. Have a good day

Whatever you say, but krusader is not an operating system.

I am poorly expressed: KRUSADER allows to consult the files of my Home Assistant. Sorry

If it helps, this is how I did it

Hello lolouk44,
thank you for your tutorial.

But how do you do under hassio under the prompt “core-ssh: ~ #” to start the command?
For example: “udevadm info” gives “-bash: udevadm: command not found”

I don’t have hass.io so don’t know, but have you tried this? :wink:

The /dev/serial (and most entities under /dev) are set up dynamically by the kernel on boot or on insertion of plug in devices. The problem is most likely because the /dev entries are not being carried through to the docker container running home assistant.

At least that’s my theory.

OK lolouk44 and nickrout.
Is there a command under hass.io (prompt core-ssh) that lists all the ATTRS attributes of / dev / ttyUSB0? From the prompt core-ssh: can we access with sudo Raspbian commands?
I’m on HA for a week and I realize that the OS is bridled: it’s not very nice

Don’t use hassio then. There are plenty of other options for installing.