RGBWW color_interlock wrong behavior

Hi.

I’m not sure what’s is wrong here, but I can’t change from white to color using color_interlock: true
I’m testing with and RGBWW downlight.
I’ve mapped colors:

PWM0 -> GPIO13 -> Warm White     5
PWM1 -> GPIO5 -> Cold White        4
PWM2 -> GPIO4 -> Red (R)       1
PWM3 -> GPIO15   ????
PWM4 -> GPIO12 -> Green (G)         2
PWM5 -> GPIO14 -> Blue (B)          3

Is tasmota, everything is working fine setting PWM channels and option 37 to 0.
Now, I’m trying to make it work in ESPHome.
First problem: I always see COLOR and WHITE controls in HA for this device. The correct way should be only color controls when “COLOR” is selected or only WHITE controls when “TEMPERATURE” is selected, right?

Second problem: If I set color_interlock to false (default), I can turn on white and color LED’s at the same time. I think this is the correct behavior for this setting.
If I set color_interlock to true, RGB LED’s are turned off and I can only control color temperature and brightness…BUT the color picker and color brightness still displayng in HA device. Even if I select “COLOR” in device settings, the buld still in white mode (warn or cold), doesn’t change to color, even selecting the color.

This is my actual configuration:

esphome:
  name: teste2_rgb
  platform: ESP8266
  board: esp12e

wifi:
  ssid: "Skynet"
  password: !secret wifi_skynet_pwd
  domain: '.skylocal'
  manual_ip:
    static_ip: 192.168.22.205
    gateway: 192.168.22.1
    subnet: 255.255.255.0    
  

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Teste2 Hotspot"
    password: "ABhyjlAovXqY"
    

captive_portal:

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:

web_server:
  port: 80
  auth:
    username: jmaurin
    password: !secret web_server_pwd


light:
  - platform: rgbww
    name: "Spot-X"
    red: r
    green: g
    blue: b
    cold_white: cw
    warm_white: ww
    cold_white_color_temperature: 6536 K
    warm_white_color_temperature: 2000 K
    color_interlock: true


# Example output entry
output:
  - platform: esp8266_pwm
    id: r
    pin: GPIO4
    
  - platform: esp8266_pwm
    id: g
    pin: GPIO12    
    
  - platform: esp8266_pwm
    id: b
    pin: GPIO14
    
  - platform: esp8266_pwm
    id: cw
    pin: GPIO5
    
  - platform: esp8266_pwm
    id: ww
    pin: GPIO13    
    

1 Like

What version of HA are you running?
If it’s >2021.5 then you could be experiencing the same behaviour a few of us have observed with the updated colour-picker in HA.
There’s more info at https://github.com/esphome/issues/issues/2046