Rheem Water Softener

Fabulous!! That seems to have done it. I deleted the old custom folder, restarted HASS, pulled from git again, restarted, plugged in credentials, and I’m seeing the sensors now. I don’t have much time to poke around right now, but this looks great. Thank you @arturzx !!

For what it’s worth, I’m running Home Assistant v 2021.12.10. Python version 3.9.7.

I look forward to trying out the card.

I want to thank you for developing this. I just bought and installed this water softener. I can see the entities show up in HomeAssistant but there are no devices associated with them and when i try expose them to Homekit nothing shows up.

I too only see entities., but it’s no problem.
Please post your Homekit setup

How/ what should I post as HomeKit setup?
I’m sorry but I don’t understand.
I have home assistant installed in docker on a pi4.

Edit:
I have Iaqualink installed for the pool equipment and I can see all the sensors it has.
Also, I have the Rheem heat pump/hybrid water heater and I can also see all the sensors

@abarna21 sorry but I’m not familiar with HomeKit. I don’t know how exactly HomeAssistant entities/devices work, I wrote this integration after looking some builtin sensors and other projects.

You did a far better job than I ever could. I’ll keep playing with them when I have time to see if I can get them to show in HomeKit.

These kind of sensors are not defined in HomeKit, so even you add them, they will not be visible in the Home App.

You can pass the sensors data to Homekit via Home Assistant.

I have the HomeKit integration installed in HomeAssistant and that’s how I see the sensors from my pool and hot water heater. But the plug-in for the Rheem EcoNet has a “bridge” created and once it’s added to HomeKit it just show some data. I believe @briis is correct because I don’t think there are this kind of sensors within HomeKit to be mapped out. The ones for the pool are mostly temperature sensors and switches for the valves/pool and the one for the water heater I can adjust the hot water temp like a thermostat.
I would have liked to see how much salt I have left and how much water I have used (today) inside HomeKit, and maybe a switch for regen now?
having them in homeassistant helps with daily water consumption as in the app it only shows for current day and not the previous.

I dug through the code and poked around online a bit. Haven’t found anything yet about the shutoff valve.

I downloaded the files from GitHub and have them installed in the /config/custom_components/homeassistant-iqua-softener directory.

However, no matter what I try, I cannot seem to find the iqua Softener Custom integration for use in the Home Assistant GUI under the Add integration screen.

The Installation Instructions don’t mention anything else need to install this customization.

I’ve restarted Home Assistant multiple times, but still no luck.

Does something need to be added to the configuration.yaml file? If so, exactly what?

Thanks for any help.

Show your log after HA restart. After installation is nothing to do and integration should be visible in add integration dialog.

Hi alexbeatle

I trying to get your card working. But get and error with the lines for uploading. “end of the stream or a document separator is expected”.
Should the pictures be added another way? right now I just pasted all the code in to a new card.

[core-ssh iqua-softener]$ pwd
/config/custom_components/iqua-softener
[core-ssh iqua-softener]$ ls -al
total 144
drwxr-xr-x   10 root     root          4096 Sep 18 12:17 .
drwxr-xr-x   11 root     root          4096 Sep 18 12:24 ..
-rw-r--r--    1 root     root          8999 Sep 18 10:11 __init__.py
drwxr-xr-x    2 root     root          4096 Sep 18 10:13 __pycache__
-rw-r--r--    1 root     root         35193 Sep 18 10:11 base.py
-rw-r--r--    1 root     root          7237 Sep 18 10:11 config_flow.py
-rw-r--r--    1 root     root          3434 Sep 18 10:11 const.py
-rw-r--r--    1 root     root          2762 Sep 18 10:11 diagnostics.py
-rw-r--r--    1 root     root          3559 Sep 18 10:11 entity.py
-rw-r--r--    1 root     root          1687 Sep 18 10:11 enums.py
-rw-r--r--    1 root     root          1363 Sep 18 10:11 exceptions.py
-rw-r--r--    1 root     root          3233 Sep 18 10:11 frontend.py
drwxr-xr-x    2 root     root          4096 Sep 18 12:16 hacs
drwxr-xr-x    3 root     root          4096 Sep 18 10:11 hacs_frontend
-rw-r--r--    1 root     root          3842 Sep 18 10:11 iconset.js
-rw-r--r--    1 root     root           511 Sep 18 10:11 manifest.json
drwxr-xr-x    3 root     root          4096 Sep 18 10:13 repositories
-rw-r--r--    1 root     root          1766 Sep 18 10:11 sensor.py
-rw-r--r--    1 root     root          1538 Sep 18 10:11 system_health.py
drwxr-xr-x    2 root     root          4096 Sep 18 10:11 translations
-rw-r--r--    1 root     root          5126 Sep 18 10:11 update.py
drwxr-xr-x    3 root     root          4096 Sep 18 10:13 utils
drwxr-xr-x    2 root     root          4096 Sep 18 10:11 validate
drwxr-xr-x    3 root     root          4096 Sep 18 10:13 websocket
[core-ssh iqua-softener]$

logger:
  default: warn
  logs:
    custom_components.my_integration: warn

No Warning log entries (or higher) are entered after a full Home Assistant RESTART.

I had the same problem installing iQua-softener when I uploaded the files using SSH.
I removed the folder I uploaded. Then I added “GitHub - arturzx/homeassistant-iqua-softener: Home assistant integration for iQua app supported water softeners” as a custom repository in HACS. Then I was able to install from HACS and all worked.

This not looking as my integration.

[email protected] /data/homeassistant/custom_components # ls -la iqua_softener 
total 48
drwxr-xr-x 4 root root 4096 Aug 16 13:16 .
drwxr-xr-x 6 root root 4096 Sep  8 07:01 ..
-rw-r--r-- 1 root root 1320 Aug 16 13:15 config_flow.py
-rw-r--r-- 1 root root  278 Aug 16 13:15 const.py
-rw-r--r-- 1 root root  417 Aug 16 13:15 manifest.json
-rw-r--r-- 1 root root 9322 Aug 16 13:15 sensor.py
-rw-r--r-- 1 root root  307 Aug 16 13:15 strings.json
drwxr-xr-x 2 root root 4096 Aug 16 13:15 translations
-rw-r--r-- 1 root root 1174 Aug 16 13:15 __init__.py
drwxr-xr-x 2 root root 4096 Aug 16 13:16 __pycache__

Thanks for the tip.

  1. cleaned up the old files/directories
  2. reinstalled HACS
  3. add the iQua “custom library” via HACS/download
  4. RESTARTED Home Assistant

In the HACS screen the newly downloaded HACS integration appears:

iQua Softener

Home assistant integration for iQua app supported water softeners (http://jumbosblackbox.ddns.net:8123/hacs/repository/525335933)

…but when I click on the card it just takes me to “about” page of the IQua repository. It never asks me for my iQua account information.

If I go to Settings/Add integration, and search for iQua Softener, it still never shows in the list of available integrations.

blank images I used

circ_grey_0
circ_grey_25


circ_grey_75
circ_grey_100
circ_blue_0
circ_blue_25

circ_blue_75
circ_blue_100

Corrected the code. Looks like the forum tried to integrate the pictures into the code. Try again, with the pictures which I’d uploaded separately

Got it going.

Maybe “patience” was the key?

The next morning I went back to the main “Add Integration” page and the iQua Water Softener was available for configuration.

One question though:

Why are not the multiple “entities” grouped under a Water Softener “device” like many of the other “integrations”?

Thanks for the help Lars and arturz.