Ring 401 error. client error unauthorized for url

I hope someone will figure this out. I have been running the same configuration.yaml with different installs of hass.io and home assistant docker. Ubuntu server and a raspberry and I never had any issue conneting with Ring. Now I setup home assistant via docker compose and ring fails to work. I keep getteing invalid config and 401 error. client unauthorized for this url https://api.ring.com/clients_api/session

my ring entry in config is exact. Any ideas why this set up isnt working?

i have the exact samen issue!, I’m running hass.io

I’m having the same issue as well. I’m running hassbian and Home Assistant v0.70.1.

I tried doing a POST to that URL, but it tells me the following: {“error”:“You need to sign in or sign up before continuing.”}.

Disclaimer: this was just me dorking with the API. I don’t know if this is how the request is supposed to be formatted. This was just an example I found.

I was using the following request when I get the error response:

curl -X POST "https://api.ring.com/clients_api/session" \
     -H "Accept-Encoding: gzip" \
     -H "Accept: */*" \
     -H "Content-Type: application/json" \
     -H "Host: api.ring.com" \
     -H "User-Agent: Ring/0.67 (Mac OS X Version 10.12.4 (Build 16E195))" \
     -H "Accept-Language: en-US;q=1" \
     -u ring_user_here:ring_pass_here

I’m having the same problem, trying to configure Ring doorbell and I get 401 auth error on the api.ring.com call on Hass.io 0.70.1 on Raspberry Pi 2. My username and password for Ring is correct (I’ve tried it with doorbot and it works fine).

Unable to connect to Ring service: 401 Client Error: Unauthorized for url: https://api.ring.com/clients_api/session

I’m having the exact same error, I’m running hassbian:

[homeassistant.components.ring] Unable to connect to Ring service: 401 Client Error: Unauthorized for url: https://api.ring.com/clients_api/session

I’m also sure my username and password are correct!

I can also confirm this issue on a fresh Hass.io 0.70.1 installation on a Pi 3.

It looks like this is a newer issue which the component maintainer is aware of: https://github.com/tchellomello/python-ring-doorbell/issues/94

2 Likes

I managed to find an old .ring_cache.pickle file that contains a valid auth token, copied in my .homeassistant folder, and it started working again :slight_smile:

I’m also having problems with ring on hassbian. I also noticed that I am getting server connection issues in the official ring app on Android. It seems they are having a few problems or are making changes.

I did that too but it only cleared up one error. Still tells me invalid config

Cool. Thanks. Still odd to me if it’s a ring issue then why do I have 2 fully functional hass.io installs that don’t have this ring issue?

i moved from venv on Ubuntu to a docker setup yesterday and this appears to only be in the docker.

1 Like

Maybe it’s because hass.io is a docker? It’s really not meant to run inside docker as it’s supposed to be standalone system. I was also thinking because it supervisor docker. Still, I have a different drive with the exact same setup and it works with no problems.

I am curious if this issue with ring is happening on home assistant installs or just hass.io?

I’m running home assistant v0.69.1 and I have the same error!

1 Like

It seems the issue only occurs if HA needs to obtain a new auth token. This explains why it still works for some people but is broken for people doing fresh installs. It also makes sense because Ring change their API for obtaining auth tokens.

1 Like

Makes sense. I guess. Now what’s the hass.io peeps doing to fix it? It’s a critical aspect in my smart home.

same error after changing my password

Just got my ring, hope this is fixed soon.

Looks like the changes work (i havent tested yet as i’m using docker)

So is it fixed for Hassio?