Ring doorbell camera (ffmpeg error)

Hi, I have a Ring camera doorbell but I cannot see the picture.
In the log filr I am getting this:

2019-02-21 21:21:24 ERROR (MainThread) [haffmpeg.core] FFmpeg fails [Errno 2] No such file or directory: ‘ffmpeg’: ‘ffmpeg’
Traceback (most recent call last):
File “/home/homeassistant/homeassistant/lib64/python3.6/site-packages/haffmpeg/core.py”, line 114, in open
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/asyncio/subprocess.py”, line 225, in create_subprocess_exec
stderr=stderr, **kwds)
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/asyncio/base_events.py”, line 1191, in subprocess_exec
bufsize, **kwargs)
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/asyncio/unix_events.py”, line 191, in _make_subprocess_transport
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/asyncio/base_subprocess.py”, line 39, in init
stderr=stderr, bufsize=bufsize, **kwargs)
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/asyncio/unix_events.py”, line 697, in _start
universal_newlines=False, bufsize=bufsize, **kwargs)
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/subprocess.py”, line 709, in init
restore_signals, start_new_session)
File “/opt/rh/rh-python36/root/usr/lib64/python3.6/subprocess.py”, line 1344, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘ffmpeg’: ‘ffmpeg’
2019-02-21 21:21:24 WARNING (MainThread) [haffmpeg.tools] Error starting FFmpeg.

Any idea how to solve the problem?

When I run ffmpeg I get this, so it is working.

[homeassistant@home .homeassistant]$ ffmpeg
ffmpeg version N-93214-g7e4d3db Copyright © 2000-2019 the FFmpeg developers
built with gcc 4.8.5 (GCC) 20150623 (Red Hat 4.8.5-36)
configuration: --prefix=/root/ffmpeg_build --pkg-config-flags=–static --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --extra-libs=-lpthread --extra-libs=-lm --bindir=/root/bin --enable-gpl --enable-libfdk_aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libvpx --enable-libx264 --enable-libx265 --enable-nonfree
libavutil 56. 26.100 / 56. 26.100
libavcodec 58. 47.102 / 58. 47.102
libavformat 58. 26.101 / 58. 26.101
libavdevice 58. 6.101 / 58. 6.101
libavfilter 7. 48.100 / 7. 48.100
libswscale 5. 4.100 / 5. 4.100
libswresample 3. 4.100 / 3. 4.100
libpostproc 55. 4.100 / 55. 4.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]… {[outfile options] outfile}…

Use -h to get full help or, even better, run ‘man ffmpeg’

Maybe you need to set ffmpeg path in config


  ffmpeg_bin: /usr/bin/ffmpeg

So… I battled on this a bit and wanted to give you guys answer on how I fixed it.
In summary you need to install ffmpeg … but when you do try it via apt type install some of the componenets are missing.

On my raspberry pi 3 - I’m running Raspbian Release 10 buster. Open putty and do this
STEP 1 - check you release using this command:

lsb_release -a

STEP 2 ADD a line to your /etc/apt/sources.list like this:

deb http:// ftp.de.debian.org/debian buster main

STEP 3 - install ffmpeg
sudo apt install ffmpeg

STEP 4 restart home assistant