Ring: Error: 401 Client Error: Unauthorized for url


I’m running hass.io on a Raspberry Pi 3. When I want to setup my Ring configuration as stated on the HA website I get this error. When searching (here and on Google) I saw that Ring doesn’t have an API. Does that have anything to do with this error or is there still a way to fix this?


Which Ring device are you talking about? Did you enter your username and password in the configuration? Could you please post your code.

1 Like

Sorry. It’s a Ring Video Doorbell. Here’s the code:

# Ring
  username: !secret ring_un
  password: !secret ring_pw

Do you also have this in your configuration?

  platform: ring

Do you have the Ring protect plan?

No, I have the one from the binary sensor, since the camera is only for a real camera and not for the doorbell (so far as I noticed online), but normally it should activate it with only the code I provided in the previous post. (FYI: I also tried it with the binary sensor code on it, then it gives me 2 errors, with the second being that this code is incorrect since it’s not initialized)

As far as I understood, it doesn’t work for cameras but only for the doorbell camera.

Can you please show the full error you get?
I don’t own any devices from Ring, so the only thing I can suggest is double checking your login details.

Complete error is:

Error: 401 Client Error: Unauthorized for url: https://api.ring.com/clients_api/session
You will need to restart hass after fixing.

and if I open that side, I only see this:


What site are you opening?


Do you have 2 Factor authentication enabled in Ring?

No, I don’t

Sorry, then I’m out of ideas. Restart home assistant?
I saw an authorization issue on Github when you have 2FA enabled in Ring, but you don’t
I saw another authorization issue on Github but this has been solved over 1 year ago.

Yes, I saw the one of the 2FA also. But no problem, thanks for your time. Maybe someone else will reply with something that can point me in the right direction.

May need to ping @tchellomello to look into this. :wink:

I am also getting this error now :frowning:

1 Like

Whoops, I just started getting it as well about 10 minutes ago

I’m getting the same error too. It was working a few hours ago… Confirmed account does not have 2FA.
"Ring Setup

Error: 401 Client Error: Unauthorized for url: https://api.ring.com/clients_api/session"

Yeah, I am getting the same error and my integration is not working.
I know that Ring recently had some security breaches and I believe they might have made some changes to the API.

Who’s the maintainer for the integration? They would need to look into this I believe.

Same error here. Noticed it after a restart this evening.

Yes same here. Worked before and error out after a restart.

I read about some issue Ring had where certain accounts were accessed by hackers. I bet they closed the loop on this and shut down this avenue. Sucks.