Ring integration not successful

Home Assistant 2023.9.3
Supervisor 2023.09.2
Operating System 10.5
Frontend 20230911.0 - latest
This is a Home Assistant Green box

I apologize in advance if I am asking a redundant question or if it s in the wrong forum, I am two weeks in with HA and still learning the ropes.

I have figured out a lot of stuff integrating various things into HA but Ring has me stumped. Won’t install

Hereare the steps I take:

I go to settings/device and services / + add integration.

I search and find Ring

I run it and put in my username and pass for Ring (which I tested on the ring site and works)

It sends a text with a 2fa code, I put that in as well.

Then I get a "Success! Created configuration for my email address.” message.

Thats it.

I now see a Ring device and it even says one entry however it also says “no devices or entities”.

I have read and re-read the official documentation for Ring at Ring - Home Assistant

There are no further steps to take according to this documentation, what am I missing? Can anyone help me please?


Have you tried shutting down / rebooting?

Many times

Is there anything in the log file?

Perhaps removing them reinstalling the Ring integration.

Other than that, I’m out of ideas.

1 Like