Ring motion (binary sensor) not detected

I have my Ring camera connected to HA. I can see the video preview in a card. I also have the binary_sensor enabled. But in the History, the camera motion is always “Clear” 24/7 even though my Ring app shows motion (like at 2:19pm). I looked in the Logbook too for the entity, and there’s nothing.

I’m on v0.99.0 running on CentOS.

Rang the Ring doorbell (has a binary sensor enabled), and nothing there either. Still says “Clear” forever, even though the Ring app had the alert. It detects the light on just fine.

I can walk by the cameras and both the Ring app and Alexa receive the motion event.

What am I missing?

1 Like

did you ever solve this as I am having similar issues now using hassio 0.100.2

The ring sensors update correctly with time motion detected etc but the binary_sensors, which I use to turn lights on etc if movement detected, are not updating.

Yes it’s still an issue for me, I never get motion alerts (even though the Ring all shows the motion history).

I think my issue must have been a problem with the ring cloud, the binary_sensor.ring_last_motion was working so I could turn a light on when movement was detected, they stopped working so I switched my automation so the light came on if the sensor.ring_.last_movement time changed.

This worked but there was a longer delay. I left it a few days and then tried the binary_sensor again and it worked as it did before so the only thing I can think of is it was a glitch @ ring

Did you ever solve? Are ring sensors working as of today?

After upgrading HA and re-configuring Ring with the new integration, yes it seems to work. I have doorbell ring sensor history etc.

do you see the window/door sensors too?

I do not have any window/door sensors.

Is anyone experiencing this issue again? My last ring motion according to HA was last night, but in the Ring app I see motion all day long today.

Think the problem is at Ring.com
They have issues:
Our processing infrastructure is running behind which is causing delays in receiving notifications and video recording availability. No data has been lost and the system should be caught up shortly.

Hopefully that is the case. Although I am getting push alerts from Ring almost immediately. They just don’t come through to HA.


Has this issue ever been resolved? I have the Ring Doorbell integrated within ST as well and get immediate motion events once detected. I get nothing from HA (binary_sensor.front_door_motion) although the entity sensor.front_door_last_motion updates immediately reflecting the correct time/date and the camera.front_door captures the last_motion to video.

Here is the automation I have been using and it never seems to trigger

  alias: 'Ring Motion Active'
    platform: state
    entity_id: binary_sensor.front_door_motion
    from: 'off'
    to: 'on'
    service: shell_command.egmsgnopay
      message: 'HA.Frontdoor.Ring.motion.active'

@cdikland - This has been working for me for months. I would recommend two changes:

  1. Include initial_state: true - This is probably causing your automation not to fire
  2. Remove from: 'off'. - This might not have any effect, but it is not needed
  alias: 'Ring Motion Active'
  initial_state: true
    platform: state
    entity_id: binary_sensor.front_door_motion
    to: 'on'


I made the changes but I was still not getting any motion events. Oddly enough the sensor.front_door_last_motion was being updated. When all fail… Reload the integration. Voila… All working now :slight_smile:

1 Like

Reloading the integration works only a few hours for me. Is there a way to automate an integration relaod? I have looked and can’t see a way. I am new to HA and still learning.

Same problem. Sometimes, things work, sometimes they don’t. Recently I had one camera delivering the motion event, one that did not; I rebooted the camera and started getting motion events again. Today, neither camera was triggering HA - I restarted the Ring integration, that fixed it - but I know they’ll fail again.

Bottom line, the binary sensor for motion is unreliable. Even when it works, it’s slow. I’m thinking of giving up on Ring and installing some real motion sensors outside.