Ring2 keypad NOT connecting to Aeon Labs Z-stick Gen5+


I’m new to HA.

After having configured and paired zigbee elements I’m trying to configure a Zwave ring2 keypad. BUT get no result…

Platfomr: Home Assistant Core 2022.6.7 + Home Assistant Supervisor 2022.06.0

Z-Wave JS to MQTT: 0,44

Zwave JS : Driver Version: 9.5.0 , Server Version: 1.20.0

Aeon Labs Z-stick Gen5+with fw 1.2

Installed ZwveJS, and zwavejs2mqtt. Succesfully configured the Aeon Labs Z-stick Gen5+

PROCEDURE Followed to try connecting the keypad:

Power the keypad with the usb, staying at only 2meters from the stick

Then, from the control panel, I choose “Action → Manage nodes → [inclusion, Name&Location, Default inclusion mode] , then start the “interview”….

After 2 minutes nothings happens (the interview seems to last only 30 seconds of countdown)

If I go to Settings→ devices→ Zwave the keypad is not listed

If I go to the Zwave2mqtt control panel, the keypad is not listed

WHAT can I do to let the stick find the keypad ?

Thanks in advance,

I try a SMARTSTART giving the text of the qr code…
After a minute the keypad got connected…
WHY it doesn’t work with the manual procedure ?
What I was doing wrong ?
How can I check if all the keypad functionalities have been discovered correctly ?


You didn’t read the manual on how to do a manual inclusion. After you start the process in zwavejs you have to do the magic code on the device to have the device enter manual inclusion mode.

SmartStart is the recommended method anyways when available.

1 Like


Another newbie, experiencing the same issue connecting the Ring Keypad to Home Assistant.

for the background, I’m running

  • Home Assistant Blue / Hardkernal ODROID-N2
  • Platform: Home Assistant OS 10.4, Core 2023.8.1
  • Z-Wave JS UI 1.15.4
  • Aeon Labs Z-stick Gen5+with fw 1.2

Installed ZwveJS, and z-wave JS UI. Successfully configured the Aeon Labs Z-stick Gen5+

Using SMART START, I entered the DSK details and make it active.
Power up the Keypad, press the 1 key for a few seconds and can see the green LED blinking 3 times before pausing, then repeating.

Can anyone help advise how I can discover the keypad?

Thanks in advance

This is the “Classic inclusion” method. If you want to use this method, you need to start the inclusion process in the software first. In ZUI that’s Manage Nodes → Inclusion → Next, from the “hamburger” button.

If you are using SmartStart, the device includes automatically when powered on. Don’t initiate classic inclusion and wait for some time.

I power down the keypad for a minute and then DO NOT PRESS any keys - the green LED blinking 3 times before pausing, then repeating - apparently it is the same for Smart start mode as well.

I’ve waited 20 mins without any connection made.

I check the debug logs over that period, and it seems ZUI is looking for it - but I don’t really understand what is expected from the log below.

2023-08-08 18:52:02.004 INFO APP: GET /health/zwave 200 1.417 ms - 2140
2023-08-08 18:52:28.802 INFO Z-WAVE: Calling api getProvisioningEntries with args: [ [length]: 0 ]
2023-08-08 18:52:28.805 INFO Z-WAVE: Success zwave api call getProvisioningEntries [
dsk: ‘63129-64002-55884-20643-24308-33762-18924-36422’,
securityClasses: [ 2, 1, 0, 7, [length]: 4 ],
name: ‘Keypad’,
location: ‘Entry’,
status: 0,
requestedSecurityClasses: [ 2, 1, 0, 7, [length]: 4 ]
[length]: 1
2023-08-08 18:52:32.145 INFO APP: GET /health/zwave 200 1.376 ms - 2140

I haven’t had any problem using SmartStart myself, but if you’re not having any success I’d just try the classic inclusion method.

No luck using either method.

Still not working - which got me thing whether there maybe any hardware issue at play.

Both the Gen5+ and the Keypad seem to operate correctly, so I sniffed a little more using the MQTT options in ZUI.

In the debug logs I can see the following

2023-08-09 10:29:46.407 INFO Z-WAVE: Network scan complete. Found: 1 nodes
2023-08-09 10:29:46.435 INFO Z-WAVE-SERVER: ZwaveJS server listening on
2023-08-09 10:29:46.464 INFO Z-WAVE: Z-Wave server started
2023-08-09T00:29:46.478Z CNTRLR Smart Start listening mode enabled
2023-08-09 10:29:46.489 INFO Z-WAVE: RF region is not supported by controller
2023-08-09 10:29:46.630 INFO Z-WAVE: Next update scheduled for: Thu Aug 10 2023 00:00:00 GMT+1000 (Australian Eastern Standard Time)
2023-08-09 10:29:47.263 INFO Z-WAVE-SERVER: DNS Service Discovery enabled.

I am in located in Australia. I locally purchased the Gen5+, but not the Keypad was purchased over Amazon from the USA as it is not sold separately in Australia

Checking Aeotec help desk provides the disappointing information

Can a firmware upgrade for Gen5 products be used to change their region or frequency?[ Print](javascript:print():wink:

Modified on: Mon, 25 Jul, 2022 at 12:39 AM

Unfortunately, due to limits with the Z-Wave chip and various countries’ legal requirements, the frequency and region of a Gen5 product can’t be changed by changing a device’s firmware.

The firmware does tune the frequency usage of a Z-Wave device, each Z-Wave module has a physical SAW filter installed upon it. This SAW filter hardware defines and improves each device’s signal-to-noise ratio (noise from other frequencies) of a specific frequency. In doing so, it also prevents the changing of a Z-Wave frequency upon any device.

Please note that upgrading a device using the improper firmware region may brick the Z-Wave chip, rendering the device broken and voiding its warranty.

I’m not sure that are any option anyone can suggest see to get this hardware working?

Buying a Gen 5+ from the USA or choosing another Keypad for my Alarmo integration is the worst case I guess, but I wonder what issues are waiting to be discovered?