Rinnai Heating/Cooling Wifi Module

Hi guys,

I have a different issue, i am not able to do the initial setup of rinnai touch wifi box. I changed my router wifi ssid and needed to reconfigure it. It was all working fine before this. But after i reset rinnai touch wifi i am not able to connect to it anymore. Even direct connection to rinnai touch wifi in ap mode is not working. Basically I reset Rinnai Touch wifi according to Rinnai website. I.e. I hold the AP button on rinnai touch black box and then switch it on, wait till orange light and release ap button. I can see Rinnai SSID to connect my phone wifi but I am not able to connect to it. Password seems accepted when connecting to RinnaiL700MP ssid but then i dont see an IP address is issued to my phone. And when i tried to configure the rinnai touch ios app it says Rinnai touch not found. Seems like the Rinnai black box is not able to issue IP address to my phone to configure it. And also the ssid says weak security. May be the firmware on it is damaged.

If you have rinnai touch wifi can you confirm what is the default IP range for AP mode setup. I may try setup the my phone ip manually instead of DCHP and see if the rinnai app is able to recognize it.

Another solution I am thinking if anyone know how to update the rinnai touch firmware via the usb port on it?

I don’t know about iPhone, but my phone has trouble in similar ways because the AP doesn’t provide internet and the phone usually starts to “smartly” fall back onto a different connection. You can either st if that’s a function your phone has or temporarily turn off mobile data while doing the setup.

Gday first time poster. Is there a walkthrough for this yet? I am having a hell of a hard time.
Got HACS installed, but cannot find any repositories for Brivis/Rinnai.
Tried using SSH and installed git clone as per GitHub - funtastix/rinnaitouch: Rinnai Touch Wifi Integration for Home Assistant. Works with Rinnai and Brivis systems. but still cannot find repository.
Have tried restarting and refreshing.
Any help please?

In HACS, navigate to Integrations, use the Add button to add one, and search for Rinnai. It should come up. No need to fiddle with git clone and the like.

This seems to be a reasonable guide: What is HACS and how to use it? - The Home Automation Blog

Thanks for reply. It still doesn’t come up. Could it have disappeared with latest update maybe?
This is all that pops up when you start to type ‘Rinnai’.

Have a look at your list of custom repositories. Does GitHub - funtastix/rinnaitouch: Rinnai Touch Wifi Integration for Home Assistant. Works with Rinnai and Brivis systems. already show up? If not, add it. Then, just search for it (rinnai) on the integrations page and go from there.

OK that fixed it thanks very much.
Any other n00b out there, if you go into HACS, then ‘Integrations’, then click on the three dots in top right, then ‘custom repositories’, then paste the clone code from GitHub - funtastix/rinnaitouch: Rinnai Touch Wifi Integration for Home Assistant. Works with Rinnai and Brivis systems.
It should then appear in ‘Explore and download repositories’ button down the bottom, where you can search ‘Rinnai’ and it will popup, where you click on it and download.
Yay

2 Likes

I’m running the funtastix implementation and having an issue with the temperature sensor

I have the Nc7 touch controller too

If I do the install just using the rinnai touch section (no zones or common zone) the main temp sensor is unavailable /reads 0

If I do the install and also select the common zone, then the common zone temp sensor shows a value (which I assume it’s getting from the Nc7 touch unit)
All of the other “common zone” entities show as unavailable

I think this is a bug… I want to get the temperature to read in the main sensor section
Any ideas?

It’s looks like the temperature is reported against the common zone by the unit. Can you follow the instructions in GitHub to enable debugging and send some debug logs here?

Certainly. I’ll do that when I get home.

I am thinking it might be something wrong with that module too actually.

In the last week, the module has started flashing error code 7 on the wifi LED. (can’t connect to the cloud)

I can get it to connect to my wifi, get an IP address, I can browse to the modules Web page, get the phone app to connect etc etc.
It just won’t connect to the cloud, allow outside access etc.

I’ve reset it and set up from scratch several times, made sure port 50000 and 27847 are open, tried it on my home router (asus) ISP router (telstra) to rule out any router incompatibility,…

I’m going to see if the store I purchased it from can lend me another one to try, so I can work out if it’s a module problem or a router problem

Bit annoyed as it’s out of warranty and they cost $350 to buy (bloody rip off)
Someone needs to reverse engineer the firmware to put on a esp32…

UPDATE: I just ordered a new wifi controller module. Don’t want to waste anyone’s time trying to help with a known suspect controller… I’ll post a debug script when I have the good one in a few days :pray:

And yes - it is a bl00dy ripoff!

1 Like

Can anyone suggest a place in Australia to buy a replacement rinnai touch wifi module? (under $400!)

Just about everywhere seems to be out of stock.

I ordered one from someone on ebay and after 2+ weeks it still hasn’t been sent and I’ve contacted ebay for a refund.

Found it here: Brivis / Rinnai Touch Wifi Controller Gas Ducted Heater Evaporative Co – EcoLux Appliances

I got a new one last week for $355 here…

Unfortunately did not change my reliability issues

What were the reliability issues you were having?

Wondering if I just rip the bandaid off, ditch the Nc7 touch controller and use some other method that works with home assistant…

The Brivis Touch Wi-Fi Kit operates with NC6’s (master /slave) also. You don’t need the NC7.

Regardless of the Network Controller type, the issues are likely the Brivis Touch Wi-Fi Kit unit itself. It’s a poorly designed expensive piece of shit. The fact that a A/C controller cannot report the current temp, demonstrates how bad the design is. It was an after though and a tactical product to fill a glaring gap.

Brivis don’t offer any support. In terms of technical competency, Brivis (Rinnai) are at the pen and paper level. The WiFi kit was developed by a third party that’s complete invisible and Brivis don’t even understand the product they sell. There’s so many issues with the product to warrant listing, hence no one wants to sell it.

These are the opinions of an installer who provided my unit and told me I’m wasting my money.

It’s a real testament to the authors of this addon, that they managed to get it this functional.

1 Like

Finally got this to the point where I can find it in the Add Integrations.
But now I just get:
Error
Config flow could not be loaded: {“message”:“Invalid handler specified”}

Any hints?

Can you add a screenshot?

Update*
I went back into HACS and redownloaded it.
Then did a full restart of the docker container (not just from in the ui interface)
Now it looks like its working, ive got to the Rinni Touch IP and zone config options

Sorry about the delay Marty,
I am pretty sure that the 1st Module I purchased a few years back was dodgy from the day I took it out of the box,
It was reporting very low WIFI signal, despite being a meter away from the Access point. Every now and then it would just drop off wifi, meaning it couldnt be accessed, meaning any automation I had setup could fail because the module was offline.
I put it behind a smart switch so I could automate power cycling it, but that was not a 100% guarentee it would recover wifi, after putting up with this for a few years, and some attempts by funtastix to automatically recover from some errors within the addon, I still had issues, and recently, found my HA with 100% full filesystem, because the Brivis Wifi module wasnt responding and the addon was flooding the logs with multiple errors per second, filling up 60GIG of space overnight. being in Melbourne, at this time of year, it is not nice when the heating doesn’t come on in the morning and I have to debug HA in the cold.
So I finally bit the bullet and purches a new module,
my initial observation was that it was no better, as the same error log flooding immediately occurred, but looking at my Unifi logs I can see this new module is stable on Wifi, and it reports a MUCH stronger wifi signal.
Really not sure what was causing the issue where the addon was flooding the Syslog/user.logs. But I decided to disable the Funtastix addon and go back to the HomeBridge / Matorock plugin, which at least doesnt cause log flooding in HA, but it has still occssionally not responded, and so far a power cycle resolves that issue, which I have added additional steps in my automations to powercycle the module if it did not set the mode as expected, it waits 2 minutes and tries setting the mode again, which so far is successful.

So in summary, I am sure I got a dodgy PoS initially and now I am just running with a twice as expensive PoS.
I would suggest if you have a different option in mind that will work for you, go that way. but in my setup I could not see any better options.