Roborock sensors' attributes

Hello there everyone,
this is probably my first post in the community :slight_smile:

Question: I have stopped seeing the attributes of the sensors of my Roborock S5 Max (remaining hours of use of the filters, etc). It was working before, but they are not showing up now on two custom cards:
(GitHub - benct/lovelace-xiaomi-vacuum-card: Simple card for various robot vacuums in Home Assistant's Lovelace UI) and (GitHub - denysdovhan/vacuum-card: Vacuum cleaner card for Home Assistant Lovelace UI)
However, when showing the attributes on their own on a card, they show up…the thing is, both these custom cards worked before, and the only thing I did was to update HA to the latest version recently to 2021.11.1

Any help is appreciated. Also, if the correct place for this issue you think is both those 2 custom cards’ repositories, I’ll do so too.

Thank you everyone!

Read the release notes before update
It was mentioned, that the attributes are now sensors

I did read the release notes indeed. I guess I did not understand the impact of that mentioned change. And I also guess, this is something that has to be fixed on those custom cards? they do accept a “key” for the attributes, so one can provide a custom attribute/sensor, but I tried everything and nothing worked :frowning:

Post your card code.

You might want to hold off making changes for a bit though. The new sensors report in seconds. The old attributes were in hours. There is a PR to change this back to hours in progress and will be available in a future update.

type: custom:xiaomi-vacuum-card
entity: vacuum.roborock_vacuum_s5e
vendor: xiaomi_mi
name: Roborock S5 Max
    key: sensor.roborock_vacuum_s5e_main_brush_left

I’ll hold on :slight_smile:

thank you!

Ok, that’s a custom card. It will have to be updated by the developer.

EDIT: Looks like they have fixed it and you just need to update the card to v4.4.0:

Unfortunately the fix seems not to work for at least the models Roborock S5 Max and Roborock S7.

That’s unfortunate, but the advice still applies. Let the custom card dev know.

Just as I thought!
Thank you :slight_smile:

I have an S5 Max and just downloaded the latest release of the lovelace-xiaomi-vacuum-card and it worked for me:

After changing the original name of the entities for both vacuum devices themselves adjusting them to the name of the (new) sensors through the HA web interface:

Settings → Integrations → Xiaomi Miio → Roborock Device → 1 Device → My Device

(was roborock.vacuum.s5e and roborock.vacuum.s5e_2, changed it to Roborock S5 Max (unten) and Roborock S5 Max (oben))

and activating all as per default deactivated entities (sensors) for the vacuums, all labels are now showing correctly at the lovelace-xiaomi-vacuum-cards with v4.4.0 :+1:t3:

But is it possibe to make the new sensors to show hours?

I can no longer get this card working for my Roborock S5 since the 2021.11 HA update (running latest card version - v4.4.0). Has anyone else managed to? I may have to submit an issue on GitHub otherwise.