Rocky start


After a period of research I finally decided to start using Home Assistant. The installation process, using Docker Desktop, was flawless and I was up and running in 15 minutes. The autodiscovery however did not find anything. My SONOS, Hue Lighting, NEST thermostat all we not found. I tried adding the integrations through the interface once logged in, but still no luck with SONOS and NEST. I finally got the Philips Hue to work, but the rest does not link to HA.
Edit: NEST seems to be a paid service, it requires $5 to link it and SONOS still no luck.

Are you running Home Assistant Docker on Windows?

If so, wsl2(which docker uses on Windows to run containers) does not support mdns(this is needed to support discovery)

I am running HA Docker on a Mac.
Discovery on Hue worked fine from the Integrations tab, not so much with SONOS.
Also I cannot add additional repositories. It seems like that has something to do with de Docker solution. I am seriously considering a dedicated Raspberry Pi for this.

I recall autodiscovery didn´t work for me either with Sonos and added it manually in yaml prior to it moving to the frontend. Did you follow hte instructions? Sonos - Home Assistant (