Roomba Bin Full - attribute not available in HA

I just configured a Roomba 895 on Home Assistant. All seems to work well - but with this roomba, it won’t show me the bin status.

Nothing too exciting in the configuration.yaml file:

  - platform: roomba
    host: roomba.home
    username: xxxxxxxxxxxxxxxxxxxxxx
    password: xxxxxxxxxxxxxxxxxxxxxxxxxx

It shows me the following attributes when I look at the roomba component in the state menu:

"status": "Charging",
"battery_level": 100,
"battery_icon": "mdi:battery-charging-100",
"bin_present": true,
"software_version": "3.2.19+49",
"friendly_name": "Roomba",
"supported_features": 479

So, we can see that it shows me that the bin is present, but doesn’t report on if the bin is full or not.

Looking at the HA logs, I see in the logs that it shows that bin is full. But it isn’t exposed as an attribute in HA. You can see this in the part of the log that says ““bin”:{“present”:true,“full”:true}” as you can see below in the raw log. How can I get this variable exposed into HA so I can run an automation based on this?


2018-11-05 18:43:37 INFO (Thread-2) [roomba.roomba.Roomba] Received Roomba Data : $aws/things/xxxxxxxxxxxxxx/shadow/update, b'{"state":{"reported":{"cleanMissionStatus":{"cycle":"clean","phase":"stop","expireM":88,"rechrgM":0,"error":0,"notReady":0,"mssnM":0,"sqft":0,"initiator":"localApp","nMssn":27},"dock":{"known":true},"bin":{"present":true,"full":true},"batteryType":"lith","batPct":100,"mobilityVer":"6636","bootloaderVer":"4","soundVer":"13"}}}'

I don’t have an answer for you, but if it helps, here’s what my Roomba 981’s showing right now with a full bin.
And when it’s not full, it shows bin_full: false
I wonder if your supported_features could be customized perhaps to make it report that? Just a guess…

status: Charging
battery_level: 100
battery_icon: mdi:battery-charging-100
fan_speed: Performance
fan_speed_list: Automatic,Eco,Performance
bin_present: true
software_version: v2.4.6-3
position: (-162, -44, -179)
bin_full: true
friendly_name: Roomba
supported_features: 511

I tried a HomeAssistant upgrade and a firmware upgrade on the Roomba and still the same.

I’ve seen the “supported_features” on a few other devices as well but don’t know how to really use that functionality.

Any one else have any ideas here?

For anyone keeping tabs on this…check out this bug that was filed in github.

Essentially there is a workaround for my ask which is documented in that issue.