Roomba Integration Issue

First time I start a post here so please bare with me.

I installed the iRobot integration yesterday. I followed the integration guide from the docs. Added the component through the hass integrations webpage and then added the following code to my configuration.yaml:

  - host: XXX
    blid: XXXX
    password: XXXX
    continuous: false
    delay: 5

Everything was working fine (roomba was integrated, I could see its status and I think I even got it moving from my HASS frontend).
Today I was working on its custom card for my frontend and at some point I restarted HASS and (I think after that) Roomba was reported as unavailable. I tried to edit the integration through the online interface, but there is no editing there.
I deleted the roomba entry and restarted HASS and still nothing.
I tried to delete the integration trough the interface but it wouldn’t go away (after deleting the integration was still there).
Long story short (many restarts of HASS and other stupid things) I decided to delete all the entities of the integration.
And other unwise actions that I may not remember.

Long story short here is the situation now:

  • Without the roomba entry in my config.yaml: I get this error in the log:
2020-06-29 22:30:05 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.140591752978832] Error handling message: Unknown error
Traceback (most recent call last):
  File "/home/homeassistant/srv/homeassistant/lib/python3.8/site-packages/homeassistant/components/websocket_api/", line 95, in async_handle
    handler(self.hass, self, schema(msg))
  File "/home/homeassistant/.homeassistant/custom_components/browser_mod/", line 36, in handle_update
    devices[deviceID].update(msg.get("data", None))
  File "/home/homeassistant/.homeassistant/custom_components/browser_mod/", line 72, in update
    self.sensor = self.sensor or create_entity(
  File "/home/homeassistant/.homeassistant/custom_components/browser_mod/", line 30, in create_entity
    adder =[DOMAIN][DATA_ADDERS][platform]
KeyError: 'sensor'
  • With the roomba entry in the config yaml: I get an error in the log:

2020-06-29 22:15:05 ERROR (MainThread) [homeassistant.setup] Setup failed for roomba: Unable to import component: cannot import name 'Roomba' from 'roomba' (unknown location)

Note that I do not get the browser_mod error (error #1 above) when the roomba integration is in my config.yaml (and to the best of my knowledge there is no frontend for roomba in my system yet - so I do not understand how having the roomba integration - which is not working - helps with the browser_mod error???).
In both cases the iRobot integration has disappeared from my Integrations interface but trying to add it does nothing. (integration window exits).

Other relevant (or irrelevant) info:

  • Running HASS on Linux server (ClearOS which is like CENTOS)
  • Roomba is 980 and working fine (iOS app working fine also)
  • Got BLID and PW through dorita.

Any ideas?

The two errors are unrelated. The first is referencing a custom component browser mod. If you setup the Roomba integration from the frontend, you do not need it in your configuration. Check your entity registry for another set of entities for the Roomba but maybe with a different name or “_2” appended to it.

Thanks for your response. Indeed, the two errors seem unrelated. But, when I add roomba in my config, the other error disappears! So, there is a relation, don’t know if we can find causation…

Where should I search for roomba in entity registry? It is nowhere to be found in the Entities of the frontend (even when the integration is added to config.yaml).

As far as what is needed for installation this is not at all helpful…

Reinstalled HASS (had several issues) and issue is gone.
Not ideal, but a solution. Thanks for the help.