Roomba platform error: [roomba.roomba] Error: [SSL: DH_KEY_TOO_SMALL] dh key too small (_ssl.c:1056)

Hello everyone… Since the last upgrade to the latest version of HA from 0.102.2 to 0.103, I got an error message while loading Roomba Platform:

[roomba.roomba] Error: [SSL: DH_KEY_TOO_SMALL] dh key too small (_ssl.c:1056)

I read that to correct this error, a solution is to downgrade the SSL security level from 2 to 1… I did it and now roomba is available again but I do not like this work around (downgrading security…)…
To do that, Open “/etc/ssl/openssl.cnf”, search “CipherString” (generally last line of the file) than replace “2” by “1” , save … done (see below), I rebooted after this change to be sure…

MinProtocol = TLSv1.2

Any other safer solution (without downgrading SSL security) to make it work again ?

Thanks. Didier

Hi @browetd,

After updating my Home Assisntant do the latest 0.103 (virtual env with python3.7) I also got this problem which prevents the previously working HA 0.102.3 to integrate with Roomba.

I also changed the system default SSL security level from 2 to 1 to test (DEFAULT@SECLEVEL=1) , and confirmed that it works.
After this confirmation I changed back to (DEFAULT@SECLEVEL=2) since I don’t like to go backwards. :crab:

If you or anyone get a better way to address the SSL/Roomba connectivity issue, please share it.

Same problem here.
Roomba e5 worked perfectly and now I’m getting that same error.

Same issue here. Bump Bump. :slight_smile:

Same problem here, but for some reason even downgrading the SSL level doesn’t help… (my bad, first had to upgrade HA.

same issue here, after last HA update.

Just found out the same issue is described in ticket #19683, but for another component.

It seems the problem is fixed in HA 0.109.2 maybe before but I did not check before today (I moved back the security level to 2 in “/etc/ssl/openssl.cnf" and no error message anymore)… Roomba is working fine after a reboot.

Thanks @browetd for the heads up.
Up and running again with security level 2 :slight_smile:

What is the change of success if I update only Roomba component to v1.5.2 (I am running HASS v0.106.5 with Roomba component v1.4.2), because when I update to v0.109.3 I get the following error in logfile (Roomba component is not working at all):

2020-05-04 17:39:22 ERROR (MainThread) [homeassistant.components.vacuum] The roomba platform for the vacuum integration does not support platform setup. Please remove it from your config.

Recently they moved to a pure integration for roomba so you have maybe still roomba configuration in the configuration.yaml file… You have to remove it from the configuration.yaml file and define the platform through the integration menu : “configuration” and then “integrations”… You have to add roomba to the list of integrations. I hope this will help…