Router loses Internet connection when using Adguard Home DNS

Hi All,

Recently for some reason when I use the DNS server address of my HA (With Adguard Home) my Asus AC86U disconnects from the internet and I loose all external internet access. It has been working perfectly for months.

If I manually select one of the Adguard DNS addresses that my router has everything works

Using the same DNS in Adguard Upstream servers causes me to loose internet

Would be grateful if anyone point me in the right direction how to fix this, I am thinking it is another setting somewhere else but do not know where to look.

I am having similar issues. I have been having similar issues for the last 6 months - also using Asus Router (RT-AC87U).

I did a new install of Home Assistant and AdGuard to see if it solved the issue, but it did not.

My issue is that it works for some time, then all LAN devices lose access to Internet.

I have had similar issues with PiHole installed on a Raspbian, so to me it seems to be a setting missing in the router config.

Any help would be appreciated!

The weird thig is I have a completley different network in my house for my office running on an Asus AC68U. On this I use an old Dell laptop with just AdGuard Home installed using the same upstream DNS server & blocklist but I have no issues whatsoever with this. It seems to be something related to the Home Assistant version.

Hopefully someone will offer some guidance.

I have a ASUSWRT (Merlin) router and have never had a problem BUT I only use the google upstream servers (

If you switch to the google ones, do you have the same issue.


When you change the DNS address to the HA machine for your network, what do the devices on your network connected to your router say the DNS server is? Do they say the address of the HA machine or the address of your router?

When going through this with my router (Netgear Orbi) I discovered that the orbi proxies DNS through itself by default. So the Orbi router is the DHCP server on my network it tells all the clients its address is the DNS server on the network, regardless of what I put in those DNS boxes in the settings. Then the orbi makes a call to whatever DNS server(s) I specify.

This creates a big problem if the DNS server you list is an internal IP address inside the network. This loopback inside the network makes a giant mess. DNS essentially couldn’t resolve on my network in this configuration (or if it did it was incredibly slow).

If this is what’s happening to you then there’s four possible fixes:

  1. Find the DNS proxy setting and turn it off. Hopefully your router has a setting for it (mine unfortunately did not)
  2. Manually modify every device on your network to tell them to use the IP address of HA as the DNS server and not the one they get automatically. Unfortunately many IOT devices don’t have this option so you probably will have a bunch that aren’t going through your local DNS server if you go this way. Works for phones and computers though.
  3. Make Adguard Home the DHCP server for your network and turn off DHCP in your router. Then Adguard will serve its own IP as the DNS server to everything. It works but there’s a catch - if the HA machine or adguard goes down then your whole network is down.
  4. Don’t use a local DNS server and just put the public Adguard IP address in your router like you show above.

I went with #3 personally but can tell you the cost is steep. Rebooting the machine has to be scheduled since it takes down everything and issues with the HA machine are suddenly really serious since the whole family and every device on the network is impacted. If you do have to go with #3 I strongly suggest giving your laptop a static IP address and not having it ask for an IP address via DHCP. That way if shit hits the fan at least your laptop still has network access and you can start troubleshooting.

I have not tried the Google Upstream server but will thank you

Once I get the house to myself later today lol I will check to see what DNS settings devices have that are connected to the router.

The weird thing is that as I mentioned above I have another network for my office with a similar Asus router but use a dedicated old laptop for Adguard and have zero issues with it. Only Adguard in Home Assistant gives me issues

Did you get it to work? I have the same issue.

Using adguard with cloudflare dns, upstream tests shows no issues but when I point my router to HA, my router (asus ax-92u) tells me internet is disconnected. It has been working without a problem for months but for maybe 2 months ago it suddenly stopped working and I haven’t go it to work since then.

If I recall correctly, there was an adguard update (and then another shortly after) for about two months ago. I don’t have any proof but it seems related to the adguard update.

Mentioned problem reported on adguardhome repository Router setup stopped working


  1. Set the custom DNS in the DHCP area DNS settings.
    (Leave WAN DNS settings as default, connect automatically)

  2. @CentralCommand Make Adguard Home the DHCP server for your network and turn off DHCP in your router. Then Adguard will serve its own IP as the DNS server to everything. It works but there’s a catch - if the HA machine or adguard goes down then your whole network is down

    (Leave WAN DNS settings as default, connect automatically)

Some brands have restricted in firmware to prevent use the same network segment in WAN settings due DNS server provided by some internet service providers are same as the LAN IP addresses.

1 Like

Just thought I would update everyone,

I have had Adguard Home disabled in Home Assistant since the problem began, instead I was using one of the pre defined Adguard DNS servers in my Asus AC86U. Just now I decided to turn on Adguard in HA and point my Asus DNS setting to my HA installation and it is now working. Have no idea what resolved the issue, possibly a HA update or firmware update on my router.

Anyway for now it is working

1 Like