RPC Shutdown stopped working (FRITZ!Box 4040 problem)

So it seems I have a bit of a problem tracking down the root of my problem.
The problem being that the RPC Shutdown add-on stopped working after some changes.
Before I round up the suspects, here is the log output from the add-on:

[12:35:56] INFO: Read alias: PC
[12:35:57] INFO: Shutdown PC -> 192.168.xxx.xxx
Could not connect to server 192.168.xxx.xxx
Connection failed: NT_STATUS_IO_TIMEOUT
Could not connect to server 192.168.xxx.xxx
Connection failed: NT_STATUS_IO_TIMEOUT
[12:36:07] ERROR: Shutdown fails ->

Suspect 1: Before I was using my ISP provided modem as a router too. I put it into “modem-only” mode and put a Fritzbox 4040 behind it as my router. After setting it up everything seems to work fine…

Suspect 2: The same day (yesterday) I added my router Windows 10 had an update and since everything seemed to be working with the router, of course I applied the update and restarted.

So either of the suspects could have been the cause, but I’ve been focusing mainly on the router but can’t seem to find much about my specific problem. (There is a lot about registry settings in Windows and stuff like that, but please remember that the add-on was working the last 2 years…)

UPDATE: I unplugged my router and reverted my modem back to router mode… RPC Shutdown add-on works again, so I now know the problem is my Fritzbox 4040. I hope somebody with a Fritzbox knows what my problem is, as I’d really like to use it…

Obvious question, but doesn’t your win10 change IP when switching routers?

Normally it would change IP with a DHCP router, but I give most of my devices a static (reserved) IP in the router. So yeah, I forgot to mention that in the “setting it up” part of the Fritzbox…

Try to ping your PC from HA to assess connectivity…

Pinging my PC from HA (rpi4) was/is no problem.
Not to sound mean, because I really appreciate you thinking about my problem, but I tried a LOT of obvious stuff already.

  • Restarted every single device on the network multiple times
  • HA sees all my wifi devices (several ESP sensors/devices) and can control them as before
  • Pinging works both ways between my PC and HA
  • Searching Google with the little info I have (only logs of the add-on, no mention of the incident on PC and router). Most results are of DNS settings and “DNS Rebind Protection”, but I soon came to the (to me) logical conclusion that as I’m using the actual IP adres, what does DNS have to do with it ? right ?
  • Tried to change every setting on the Fritzbox that seemed even remotely connected to my problem…

I think I might need to contact AVM (company behind Fritzboxes) even though I’m pretty sure someone else would have encountered this if it was an obvious setting on the Fritzbox :frowning:

Ok. Was not obvious from the 1st post that you knew your way around networking :wink: