Rpi 4 installation

Install with Docker. I want try tommorow on raspbian directly.

got the rpi4 up and running now, following the manual instructions - its really quick!!

Probably if you run raspbian and then run hassio on that. I was wondering the same but I haven’t ordered the 4 yet, but I am planning to.

This should work but when you install docker, you’ll need to edit the sources.list to use the stretch version of Docker as the buster version isn’t available yet. After that it should work.

I got hass running, its a pretty simple procedure:

download the most recent .deb files for containerd.io, docker-ce-cli and docker-ce from https://download.docker.com/linux/debian/dists/buster/pool/stable/armhf/
and then install them in that order with `sudo dpkg -i file after that just run this command:

$ docker run --init -d --name="home-assistant" -v /PATH_TO_YOUR_CONFIG:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/raspberrypi3-homeassistant

I couldn’t get hassio to run unfortunately.

I’m new to both raspberry pi and hassio (and these forums), but I managed to install hassio on my new raspberry pi 4 running raspbian. Posting details in case it helps someone.

Install docker (instructions taken from this thread on docker ) :
$ sudo curl -sL get.docker.com | sed 's/9)/10)/' | sh

Install hassio dependencies (instructions taken from here)
$ sudo apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common

Install hassio (this part I fiddled with until I got something that worked)

  1. Save hassio installer to file: $ curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" >> hassio_install.sh
  2. Modify install script. Open up hassio_install.sh in your favorite text editor and change it as follows. Where it says “armv7l”, change that section so it looks like this:

This (https://pastebin.com/fc64mDnm) is what mine looked like after I modified it.

  1. Run install script: $ sudo bash hassio_install.sh

After that, hassio should be available.


thanks for sharing!!

And here is the video

1 Like

Thank you! this solution is working for now

I had it up and running here, unfortunately I couldn’t get the AEONSTICK s-wave to work, it simply didn’t show up, and I had the modemmanager killed and cleaned out.
So I had to go back to the RPi3b+, but at least I know it’s doable now, just have to get the usb stick to show up as well.

1 Like

Works like a charm, thanks! :smiley:

Have you seen this issue? Might have a solution for you.

Hi @Eatoff That is a very interesting thread, seems like there is a bug in the aeonstick which can be circumvented with a usb hub, very odd indeed.

Not sure what changed.
I just tried reinstalling it, and apart from buster going to release, and I had to let that change version, the install went fine, but now I see a message that it can’t fetch the landing page :frowning:

I had that problem too, then realized I forgot to change and add to hassio_install.sh the following:




Odd, I did modify it, and it showed it correctly when I opened it as far as I could see, but I’ve now removed the containers and images from docker, re-fetched the hassio-install script, remodified it, and now it downloaded it, and it’s setting it up now, finally :slight_smile:

1 Like

I got a very small and simple USB2 hub, and put it in between, then unplugged and replugged it, and then it showed up in the tty, and I can use the z-wave integration.

Does it show up without the hub now? Or hub is needed all the time, not just to trigger it being recognised?

It needs the hub in-between all the time, and if I boot the rpi with everything connected, it doesn’t seem to appear, not until I unplug and replug it.

It’s very much faster, very nice indeed.
Odd thing though, the Fritz! device tracker integration no longer works. The fritz!box are showing them as connected, but they are marked as ‘not_home’ in the device_tracker.

1 Like

That’s a bit lame about the stick, but at least it’s kind of working

I’ll give it a go next weekend with my HUSBZB stick. Perhaps it may be different being a combo stick