Rpi 4 installation

Have you seen this issue? Might have a solution for you.

Hi @Eatoff That is a very interesting thread, seems like there is a bug in the aeonstick which can be circumvented with a usb hub, very odd indeed.

Not sure what changed.
I just tried reinstalling it, and apart from buster going to release, and I had to let that change version, the install went fine, but now I see a message that it can’t fetch the landing page :frowning:

I had that problem too, then realized I forgot to change and add to hassio_install.sh the following:

/raspberrypi3-homeassistant

and

/armhf-hassio-supervisor

Odd, I did modify it, and it showed it correctly when I opened it as far as I could see, but I’ve now removed the containers and images from docker, re-fetched the hassio-install script, remodified it, and now it downloaded it, and it’s setting it up now, finally :slight_smile:

1 Like

I got a very small and simple USB2 hub, and put it in between, then unplugged and replugged it, and then it showed up in the tty, and I can use the z-wave integration.

Does it show up without the hub now? Or hub is needed all the time, not just to trigger it being recognised?

It needs the hub in-between all the time, and if I boot the rpi with everything connected, it doesn’t seem to appear, not until I unplug and replug it.

It’s very much faster, very nice indeed.
Odd thing though, the Fritz! device tracker integration no longer works. The fritz!box are showing them as connected, but they are marked as ‘not_home’ in the device_tracker.

1 Like

That’s a bit lame about the stick, but at least it’s kind of working

I’ll give it a go next weekend with my HUSBZB stick. Perhaps it may be different being a combo stick

Ok, this might be a dumb question, but how do we modify in a text editor? Can I pull the SD card and see the .sh file on my windows machine and edit it there?

I have Buster lite installed, so no desktop. I could always go back to regular Buster and plug it into a screen and edit that way?

If you created the empty SSH file in the boot partition back when you created the usb, you have the SSH daemon running, and then you can connect with putty

Yeah, I have connected with PuTTY to check it was up and running. Can I edit text in PuTTY though?

Use ‘sudo nano FILE’

I did an inplace upgrade on my Pi 3B+ (well, on a non-production 3B+ Pi with a backup of the image from the production Pi, of course…):

grep -rl stretch /etc/apt/ | sudo xargs sed -i ‘s/stretch/buster/g’
sudo apt update && sudo apt dist-upgrade

I had to restart the actual upgrade (the second line) a couple of times because it didn’t get all the necessary files and errored out, but the third time run went through. Then I did this:

sudo apt-get install python3 python3-venv python3-pip libffi-dev libssl-dev
sudo -u homeassistant -H -s
cd /srv/homeassistantstant.components.nest
python3 -m venv .stant.components.nest
source bin/activatecomponents.nest
python3 -m pip install wheels.nest
pip3 install homeassistant
hass

So far it’s running without a hitch after an hour or so, everything of settings, atuomations, scripts and Z-Wave-settings were preserved. I will get my 4 tomorrow and see if I can simply put the SSD (I run from an USB M2.SSD) into that and run with it.

Pi 4 isn’t able to boot via USB yet, so you might run into an issue there.

But there are instructions on toms hardware for how to move all files to USB, just needing the SD card to boot.

1 Like

Thanks mate, I’ll give that a go.

That’s a real bummer! Hot the hell can they go back one step? :thinking::rage:

There are a few bugs, and errors in the pi4, the usb-c connection doesn’t identy itself correctly, so an intelligent charger like one for Sony og iPhone will not work as a power source. They have said it will be fixed in a later revision, so the current one sounds like it can’t be fixed :rage:
There are also problems with the aeon Labs stick as I mentioned.

Bloody annoying! I didn’t see that about the Z-Stick. I’m glad I didn’t waste hours trying to get that to work, I will connect it via an USB hub. But of course that was ome of the things I’d like to fix by moving to the Pi 4… I’ll test the thing for a few weeks and may return it if I’m not satisfied. There’s a 30 days “testing period” in the shop I’m using. I hope my Samsung phone charger will work, though!

Edit: I found one user that is using his S8 charger without problems, so I hope the same goes for an S9 charger, I don’t think they changed them.

Edit 2: Who the hell thought it would be a good idea to fix booting from network before booting from USB SSD? I think I’ve seen one or two people using network boot and hundreds using SSD’s n the Pi 3!

It’s only if the cable is e-marked it will fail according to: