Rpi 4 installation

can you run “docker ps” to show running containers? Providing you have followed hugh_man’s method?

I’ve just had a similar problem in that the containers were in a “stopped” state so I couldn’t reach the pi on 8123

in this discussion only Jamie_Pryer managed to install it he says it works very well maybe he is so kind as to explain his passages I still haven’t tried.

1 Like

I’m up and running now following the the guide from hugh_man… took a while to boot past the preparing hass.io screen but it’s there now :slight_smile:

Pi 4 4GB

Thanks, yes, seems to be something with the container. Got the below message running the “docker ps”

pi@raspberrypi:~ $ docker ps
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.40/containers/json: dial unix /var/run/docker.sock: connect: permission denied

$ sudo docker ps :slight_smile:

It might be worth installing “Portainer” - it’s a nice GUI to manage all of your docker containers


Oh dear…:slight_smile:
Ok, it is there isn’t it? I’m running on a 2Mbyte Rpi 4

pi@raspberrypi:~ $ sudo docker ps
1ded78ec2e73 homeassistant/raspberrypi3-homeassistant “/bin/entry.sh pytho…” 2 hours ago Up 11 minutes homeassistant
55e7c48e6f76 homeassistant/armhf-hassio-supervisor “/bin/entry.sh pytho…” 2 hours ago Up 28 minutes hassio_supervisor

can you try http://localhost:8123 on the pi browser?

Yes, that is working!! :smiley:
…and then what might be the issue to get it “public” so i can run on other devices?

Portainer gave me the below? Do the homeassistent need to have published port similar to portainer?

1 Like

so i just followed the standard steps here: https://www.home-assistant.io/getting-started/

however i used the rpi4 version of Hassio.
i also made sure i formatted my card properly, as its a 64gb one

im currently on:

System Health

arch armv7l
dev false
docker true
hassio true
os_name Linux
python_version 3.7.4
timezone Europe/London
version 0.96.5
virtualenv false


mode storage
resources 14
views 20

You should just be able to navigate to the Pi’s IP on port 8123?

Well i believe the published ports 8123:8123 is missing looking into the Portainer. Hence i cannot access Home Assistant externally.
I believe something went wrong during the installation and I have not figured out how to add published ports in Portainer. I have tried to enter the homeassistant container…but no luck so far.

Your setup looks just like mine, no ports are published on mine either.

Can you ping the pi from another device on the network?

Are you using wireless setup or Ethernet?

When you are using network = host you won’t see published ports. This is normal and how hassio works, and how home assistant in docker is recommended.

Sounds to me like you have a bad config or wrong image. What do the logs tell you?

1 Like

dankitchen and flamingm0e,
Thanks and how odd, suddenly the direct IP access works from PC, i.e. in my case
However i still cannot access via hassio.local:8123 or http://hassio:8123

Found other with similar issues but not sure what to do Can't access hassio.local:8123, only numerical IP address
I have an ASUS Lyra router

Does your router support loopback or hairpin Nat?

Thanks and I’m trying to find out…it is the fairly new “mesh” 3 pack Asus Lyra.
I can access the HA using http://raspberrypi:8123/ so i guess it is working?

that doesn’t indicate hairpin NAT at all. That’s simple name resolution (mDNS, DNS, etc)

I’ve tried installing the latest beta (64 bit RasPi 4) from here. It installs fine and boots up. I can set up an account. Then I copy my snapshot from my Pi3 setup over and restore it. When I reboot, it just gets stuck at “Preparing Hass.io”. Let it sit all night. Same thing. I’ve tried it twice. Any way I can get insight into where it’s failing?

EDIT: Ok, silly me. The return to “Preparing Hass.io” was actually my browser being cached on the original IP. When it rebooted, it got a new IP. But connecting to that new IP is still a non-starter. When I look at the log file, it’s complaining about “sqlite3.DatabaseError: database disk image is malformed”. Going to keep working on it but wanted to make sure I updated my discovery.

I have simply taken the pi 4 image provided and set it going. All works fine.
However I saw mention that this version was not as complete as the pi 3 variety.
Is this still the case ? and if so where can i find the issues list so I don’t bang my head pointlessly as I flounder to add stuff and learn. I am starting from scratch.