RPi HASS "forgot" auto login after restart, asking for console login

Dear All,

I have a very basic HASS setup running on an RPi4 (from standard image). When I restart the system or there is a power outage, it does not “come back” to the HA GUI, but shows a console screen asking for login. Earlier - in such case - it started automatically and everything was running as it should. For a while - without changing anything - it asks for console login. With “root” and “login” commands I can start it, but why do I have to do this and why did it stop logging in automatically? It is very bad, because in case of a restart / power outage I need to manually login every time…

Thank you very much for your help!

Guys, could somebody please help me out in this? :pray: Thanks very very much!

Could somebody help me please? :frowning:

I’ve been having the same issue for a few weeks now and am wondering the same as @jegember

Did you find a solution?

Amyone else understand why I have to manually log in via the console to get Home Assistant to start up? It’s been working fine until recently … I noticed after a power outage.

I noticed that systemd failed to start (systemctl status) and that the culprit was systemd-networkd-wait-online.service

I made the following change in /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service

ExecStart=/usr/lib/systemd/systemd-networkd-wait-online --any

I found the solution here

Since then home assistant has been booting up properly.

(Before making that change i had also disable ipv6, but it seemed that the issue persisted)