Rpi-update leads to 100% loadout

Mostly i do “rpi-update” on any Rpi i own, doesn’t matter what it runs.
Sadly, last time i did this (early Dec.) it leads to 100% loadout on my Hassbian :frowning:
Wenn i disconnect power and connect it again, i am able to reach the frontend, SSH, Samba and such …
Also when i connect through SSH and call up “top” it runs like a charm.
But when i disconnect it takes a few seconds and the green light keeps on all the time, so it seems like loadout is at 100%, i cannot reach the frontend, nor connect through SSH. The RPi does not even react on a ping.
Reconnectiong the power it tells me some free blocks are mapped wrong, restarts the system and the whole thing starts over.

Is there a way to “recover” the old installation before rpi-update? Or is there only a reinstall left?

You can downgrade to an earlier kernel with rpi-update options.

BTW, i think you don’t need rpi-update anymore.
1 Like

Thank you!
Didn’t even know you can rollback that simple.
Just to quote one of the links you posted, so anyone else with the same question knows:

This gets you the latest bleeding edge kernel/firmware."
sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel
will put it back to the latest supported kernel/bootcode.

Another strange thing i’ve discovered about this:
Turning on RPi with no ethernet connection does NOT lead to full loadout …

Ok … after trying several things for a while it seems like my microSD card is broken :sweat_smile:

Just one more edit: flash card seems to be ok. Data was corrupt. Must reinstall