RPi4 Bluetooth on 2022.8.1

I’m running HA OS on a Raspberry Pi4. I just upgraded to 2022.8.1 and wanted to use the new Bluetooth functionality. I added the integration and the component says

Retrying setup: Failed to start Bluetooth: adapter ‘hci0’ not found

I’m wanting to use the onboard Bluetooth I don’t have an additional adaptor plugged in.

If I select configure I get an empty dialog pop up.


Do I need to do something manually to adjust the adaptor?

I’ve sort of answered my question.
I was using flicd for the flic buttons (Flic - Home Assistant) and this seems to grab the bluetooth controller and somehow not make it available for the bluetooth integration.
Disabling flicd solves the problem but of course removes my flic buttons.

Using multiple BLE integrations that are not all based on the new Bluetooth integration is asking for these kind of issues, especially when they need to work in different scanning modes. The only solution is to use one BLE dongle per integration.

Since 2022.8.1 I have the following error on my RPi4:


2022.8.0 was fine. Seems that something was broken with 2022.8.1 for RPi4

Same here. RPi4. No other bluetooth integrations or add ons that I know of, so there should be no contention for the device.

EDIT: Found the problem. It required a full hardware reboot. Must have been something that took control of the port before HA could. Hardware reboot solved it. (not just a restart of Home Assistant Operating System)

1 Like

Great. Reboot solved the problem with my bluetooth integration, too (HA 2022.8.2). Thank you!

for me it took a step further:

sudo apt-get install pi-bluetooth bluetooth bluez blueman

Took this from tutorials-raspberrypi.de/raspberry-pi-3-wlan-einrichten-bluetooth/
I could see the adapter working on ssh executing: bluetoothctl
and then it worked in HA also :slight_smile: