RPi4 + ethernet + wifi problem

Hi all, I am solving one problem with multiple connections. I have RPi4 with Wifi USB dongle (I am not using integrated wifi as I know there are some stability issues). RPi4 is connected for (almost) all purposes to eth0 LAN to my network. I have public IP and I am using duckdns and everything is working fine.

The problem starts with secondary wifi connection. I have Solax inverter. Inverter has wifi dongle for connection to the internet. It is connected to my home network. However, the dongle also transmit its own network with SSID something like this “Wifi_SWU7…”. To get data from inverter I HAVE TO connect to this SSID. It is working fine for this purpose. I am able to get data periodically by curl REST API. BUT when I connect to this wifi everything else breaks up.

My Homeassistant IP for eth0 is
Solax inverter wifi dongle client has IP (this connection doesn’t expose REST API)
Solax inverter wifi server has IP
Homeassistant IP for wlan is

I have selected default network adapter like this:

And with this config I am unable update addons. The error is usually like that:

Can’t install homeassistant/aarch64-addon-configurator:5.5.0: 500 Server Error for http+docker://localhost/v1.41/images/create?tag=5.5.0&fromImage=homeassistant%2Faarch64-addon-configurator&platform=linux%2Farm64: Internal Server Error (“Get “https://registry-1.docker.io/v2/”: dial tcp connect: connection refused”)

I am unable to get data from integrations. For example:

Cannot connect to host api.smartthings.com:443 ssl:default [Connect call failed (‘’, 443)]

I am curious why on Earth it has anything to do with the solax inverter server. Why is it calling

If I disconnect from wifi solax dongle, everything works fine then. When I connect back, it breaks agains.

Have anybody experienced similar problem? Can anyone help me? I am missing something in configuration?

edit: I just realized, that in terminal I see this:

It looks like there is problem with DNS???

edit: finally solved it
Changed addresses to static and filled DNS servers from my provider. Then start command “ha dns restart”. Now it seems to be working.

Leave it here, if anyone have similar problems :slight_smile: