RPi4 not booting if RFLink Gateway is plugged into USB

Hello Home Assistant community.

I am new here even if I have run a HA-installation already more than a Year.
It has worked quite well, actually so well that I decided to update from Pi3 to Pi4 a week ago.

I got the Pi4 HA installed and running, imported the snapshot and all seemed fine until I tried to reboot the Pi4. It would not boot ! I conncted a HDMI screen to the Pi4, it does not even get past the PO Self test, no text on the screen.

So I disconnected my Arduino Mega running RFLINK and the CC2531 Zigbee module from USB and it booted. Plugged the Zigbee in, still running, plugged the RFLINK in, still running. After a few iterations I found out that if the RFLINK is plugged into USB it will not boot. If I leave it disconnected, boot the Pi4, then connect is works.
I first suspected I am overloading the powersupply to the Pi4 (3,4A) so I powered my Arduino Mega using an external power supply, still same problem.

Does anyone have any good hints what to look for, test or change ?

Thank You in advance

1 Like

I couldn’t find the thread right now, but I know this has been reported in these forums somewhere, I have the same problem with my setup after one of the latest updates of HA, and as far as I know there is no real solution.


Same here.
All I know is, when watching the video flux, I have the black square, but no text.
The raspberry reboots in loops.
I d’ont have the icone saying there is not enough power, so it should not be the issue.
When I unplug the RFLink device, next reboot is a success.

(I don’t know yet how to access linux logs, so no more information, sorry)

I respond to this post because I have an rp 3 with rflink in the usb port and can restart it without problems. I also have an rp 4 with almost the same configuration and as described it cannot restart with an rflink in the usb port


Since yesterday the last update Release 2021.5.1 - May 7
the problem seems solved to me.

I have the same problem, but it did not go away with 2021.5.1 nor with 2021.6.0 (and Home Assistant OS 5.13). Besides the Arduino rflink board, I have a portable SSD as data drive connected to USB.
The pi boots fine into Raspberry Pi OS (Debian) with both USB devices connected. Therefore, I suspect that Home Assistant OS is the culprit.
Initially I thought that the rpi might try to boot from one of these USB devices, so I fiddled with the rpi bootloader config (after updating the rpi-eeprom to the latest version). I tried:
BOOT_ORDER=0x1 (Boot from SD card)
USB_MSD_EXCLUDE_VID_PID=vvvvpppp (disable USB device during boot, where vvvv is the -hex- vendor_id and pppp the product_id of the device; can have multiple comma-separated device codes here)
USB_MSD_PWR_OFF_TIME=, where I tried both 0 and 5000 as values
All this to no avail.
Let’s hope that the Home Assistant OS maintainer will look into this issue.

I have moved from Domoticz to HA and I have exactly the same problem as in original post.
Pi4 with HA 2021.6.6 and OS 6.1.
I am worried that HA will not boot if temporary power loss happens.

Did anyone managed to find the solution?

Or should I swap rf-link Arduino mega for other RF device?

Hi All,
Similar issue on my side since few days.
RPI4 does not boot as soon as an RFLINK is plugged into USB Port. Note that RFLINK uses the power from the PI (not using a dedicated power plug for RFLinks). This works without issue until I tried to upgrade to HA OS 6.3.
Looks to be related to HA OS 6.3 since this appeared when upgrading to it, reverting back to 6.2 solved the issue (at least for me on HA OS 6.2 RPI4 32 bits).
Please also note that I don’t use an external USB device to boot on, I am only using SDCard.

Problem seems known and relates to devices uses CH340. Will be corrected on 6.4

I’m running Rpi4 on SSD with RFLink and 6.2 and it is not booting when connected to USB. This the issue (https://github.com/home-assistant/operating-system/issues/1011) I found from GitHub, but based on comments there is no solution insight. May I ask which issue is being solved in 6.4, so that I could check that could that solve my problem as well. As of now, I need unplug rflink, boot and then attach rflink on USB.

It seems the same with Debian. I attached an esp01 to the arduino and access rflink that way.