RTSPS Stream from Unifi camera - webRTC


I have the webRTC integration and the custom card available. When im pasting the URL for the camera in the custom card, I get the message: mse: sources unavailable: 1.

Further more, I have also installed the RTSPtoWeb - webRTC, and tried to upload a glance card with video stream. This results in a still picture from the camera, before the picture is replaced with the following error message: Failed to start WebRTC stream: RTSPtoWeb server failure: stream channel codec not ready, possible stream offline: Internal Server Error

Is it a workaround for this problem, have I done something wrong in the integrations process, or is it the fact that the stream is RTSPS, not RTSP?

Sincerely hope someone can help me!

Thank you.

1 Like

Have you got this solved? My Unifi doorbell uses rtsps and is not usable it seems with WebRTC

I got a unifi stream working with webRTC by seeing mention in Frigate’s documentation when trying to use go2rtc. Same thing works for WebRTC.

Modify the rtsps link to begin with rtspx. Additionally, remove the “?enableSrtp” from the end of the Unifi link.

Per: https://docs.frigate.video/configuration/camera_specific


@dictus.jurgen Did you try @faxxyy suggestion?
I tried putting using the url from Unifi with rtsps change to rtspx and remove the parameter ?enableSrtp from the end of the url without sucess.

I tried RTSPtoWebRTC but was unsuccessful, don’t have frigate

@dictus.jurgen @SebastianB I got this to work. Try modifying the url by changing the port number to 7747 and removing the s and the parameter at the end. I got this from the Ubiquiti forums.



Drop the second “s”

Change port to 7447

remove ?enableSrtp