Run a NUT Server on hassio?

Hello!

I found https://github.com/hassio-addons/addon-nut for running NUT on hassio.
I saw that I can run a NUT server with this on my Pi.
But it is necessary that I give the NUT server the name “qnapups” with the username “admin” and the password “12345”, because this is what my QNAP NAS is expecting.

I didn’t found something in the configuration to set the name of the NUT server. I only can set the “mode” to “netserver”, but something like " remote_ups_name" is not available when in server mode.

Can someone help me here?

This makes no sense!

1 Like

Why?

I want the Raspberry Pi with hassio to be the NUT server and my QNAP NAS should be the client. The QNAP is expecting the NUT servername “qnapups” with username "admin and password “12345”. This is fixed inside the QNAP firmware.

The QNAP can also be the NUT server and the Pi could be the client. Then I have the NUT server on the QNAP NAS which has the name “qnapups”, the username “admin” and the password “12345”.

I think I see.

Setting the username and password is obvious. You should be able to set the hostname qnapups to the ip address of the hassio machine in hosts.

I don’t think that the hostname should be “qnapups”. The name of the NUT-server on the Pi should be “qnapups”.

In the above linked documentation you can read this:

Option: remote_ups_name
When running in netclient mode, the name of the remote UPS.

Option: remote_ups_host
When running in netclient mode, the host of the remote UPS.

So you can set the remote ups_name on a remote ups_host.

But it seems there is no possibility to set the local name of the NUT-server when you set:

Option: mode

Recognized values are netserver and netclient .

to netserver, because the other parameters are only used when using netclient.

So what ups_name does the addon run as?

I opened an issue and I got an answer.

This configuration should set the name:

  "devices": [
    {
      "name": "qnapups",
      "driver": "usbhid-ups",
      "port": "auto",
      "config": []
    }

Thank you all!

Hello @carsten_h, I would like to do, like you, install NUT server on HASS.IO and to access it from other devices (my Synology NAS for example).
But, if i try to access to the Nut Server i have “connexion refused” (ping is OK, no security or network issue)(i’m using the correct user/name and ups name).
I remember that in my previous NUT Server install, i had to specify in upsd.conf the IP of the clients that would like to connect (LISTEN 192.168.1.x). But i don’t know how to do the trick here.
May you help me. Thx.

My Config: Brand new install on Raspberry Pi 4 (HA 0.118.3 / HassOS 4.16 / Network UPS Tools (0.3.1)(working fine, i can read the UPS (APC) info.

My config (NUT Add-on):

users:

  • username: user
    password: password
    instcmds:
    • all
      actions: []
      devices:
  • name: apcups
    driver: usbhid-ups
    port: auto
    config:
    • vendorid = 051d*
      mode: netserver
      shutdown_host: ‘false’

FYI, couple of days ago my Hassio setup stopped talking to the Synology NUT server. For some reason the Synology NUT server stopped using the allowable client IP’s even though they were still visible in the list. “sudo netstat -tnlp | grep ups” only gave “tcp 0 0 127.0.0.1:3493 0.0.0.0:* LISTEN 4965/upsd”. I had to close the Synology Nut server and restart and create a new allowable list. May save someone some time.