'Run Custom Command' in Alexa Media Player not Working

I have installed and configured Alexa Media Player and everything went well. I can see all my Echo devices and issue TTS to them no problem.

However, when trying to send ‘custom commands’ nothing happens. I set up a simple test automation with a trigger and an action via media_player.play_media and I get nothing. I can see the automation is executed, but I get nothing. I’ve tried multiple Echo devices and it’s the same.

This is the code:

alias: Alexa Command Test
description: ""
  - device_id: 7f64e49d492bc672e7dfb931cb78fa01
    domain: zha
    platform: device
    type: remote_button_short_press
    subtype: remote_button_short_press
condition: []
  - service: media_player.play_media
      media_content_type: Custom
      media_content_id: What time is it?
      entity_id: media_player.michelle_s_echo_show
mode: single

When I try to directly copy and paste from the Alex Media Player Wiki but change the echo to my device name, I get an error:

Message malformed: extra keys not allowed @ data[‘target’]

I’m brand new to HA and getting this working is critical to many of my automations. Thank you for the help!

Try wrapping your text in the media_content_id: with quotes.

custom must be lower-case.

Thank you so much! That fixed it!