Run HA without --net=host (for Aqara stuff)

Any way to prevent the usage of --net=host to get the Aqara component working?

Using an OpenWRT router with advanced routing options available. So maybe it is possible to forward multicasts?

what HA are you running? Docker? venv? hass.io?
I take it you use the Xiaomi Aqara hub too?
I run HA on Ubuntu 16.04 in docker with an Aqara hub and have no issues with the option network_mode: host in docker-compose…

HA 0.91.3. Docker.

I wish to stop using --net=host.

Or would switching to Zigbee2MQTT be the only solution?

Just being curious, any reason why you want to stop using --net=host?
As stated before, this should not stop you from communicating with the Aqara hub (if that’s what you have, you haven’t confirmed)

I don’t have a straight forward particular reason to stop using --nest=host, but it feels kind of overkill/unnecessary.

I have a ‘Mi Hub.’ With the round text. I think that’s called v2. Not working without --nest=host.

I was wondering the same thing. Did you get it working in the end?

No.
In theory it would require to grab UDP packets addressed to ‘224.0.0.50.9898’ and redirect them directly to the HA IP. I will continue looking tomorrow.

I enabled net-host anyway in the end. Dont remember anymore why I wanted to disable it :sweat_smile: