Running another docker container om Home Assistant (valetudo-mapper)

Tags: #<Tag:0x00007f3265af6088>

Hiya,

Recently I changed from running HassIo/Home Assistant in docker containers on Raspbian Lite, to a regular Home Assistant installation on my RPi 4. I used to have valetudo-mapper (https://github.com/rand256/valetudo-mapper) for creating the map of my Xiaomi Gen 1 vacuum cleaner.

In order to have the same result, I tried to install this docker container through the Portainer add-on in Home Asisstant. For the container to read the config file, I created the config.json in the /share/valetudo-mapper/ directory.

Next, in Portainer I configured the container by forwarding the ports (3000:3000) and the volumes; /app/config.json:/share/valetudo-mapper/config.json. Now, when I try to start the container, I get the following error message:

"Failure
error while creating mount source path ‘/share/valetudo-mapper/config.json’: mkdir /share: read-only file system"

I have already tried to change map/file permission to ‘777’ through winSCP, but unfortunately it didn’t work. Anyone have some advice on how to run this container next to Home Assistant?

Thanks in advance!

not sure this is it, but I’ve had issues with the folder owner and group in the past
You may want to check this too
here is one example:

Hmm, I can’t seem to insert shell commands. So I think this won’t work.

Problem is solved. Apparently the right mapping is /mnt/data/supervisor/share.
See: https://github.com/hassio-addons/addon-portainer/issues/11.

1 Like

I understand right?
Is there a way to save maps in xiaomi vacuum gen 1?