Running HA in Proxmox: Performance Configuration Tips & Tricks [2023]

I’d like to collect all configuration tips and tricks that optimize running HA in Proxmox in this thread. Since the configuration options may have opposing goals, such as lowering power consumption or maximizing performance, please specify clearly what the optimization is intended for.

To make it easier to read, please refrain from comments that do not add value to the thread. The ‘heart’ +1 method could be used when the suggestion works well and it ‘approved’ by others. Curious to see how this works out :slight_smile:

1 Like

IO Thread checkbox in disk settings for HA VM… according to site linked below it assigns a thread to IO so it increases performance for the VM as it no longer has to wait on other operations. I kept seeing high IO_Wait in Glances on my HA instance so I wonder whether this will help…

Quoting site linked above:

IO thread

By default, Proxmox uses io=native for all disk images unless the IO thread option is specifically checked for the disk image.

The IO thread option allows each disk image to have its own thread instead of waiting in a queue with everything else. Since disk I/O is no longer waiting due to having its own threads, it does not hold up other tasks or queues related to the VM, which in turn speeds up the VM performance besides providing increased disk performance. The IO thread option is fairly new in Proxmox. There were a few reported instances where the VM was locked up due to this option. So perform plenty of testing before implementing this feature in a production …

We could also link other threads that have useful configuration information such as this one on optimizing power consumption:


This might sounds obvious or it might surprise …

As i couldn’t close the lid ( Proxmox on laptop ), i had to apply this(below) fix … but facts turned out to show that spite it only was a black screen, with a login Prompt … Closing the lid( black login prompt ) reduced power-consumption with 5W

Maybe i should add, that i first noticed this, After i ran the “powersave” command in above PSA-link by (mchangsp) , so maybe that was a factor as-well, but still , if i open the lid “boom” +5W