Running Hive thermostat through ZHA - issues with going idle

Good morning all,

I’ve had my Hive thermostat running through ZHA for a little while. All was fine initially but I now seems to have some real issues.

As you can hopefully see from the screenshot above it keeps heating and then resetting to idle, then heating, then idle etc etc. I cannot get it to stay on ‘heating’ constantly. I’m running an air source heat pump and as a result of this behaviour I am getting no heating but consuming a lot of electricity. Is this something that it caused by Home Assistant, the thermostat or the heat pump?

We’ve currently lit a fire in the living room to keep warm but I need to try and get a solution to this issue pretty quickly. I’m just not sure if the issue is being caused by HA, Hive controller or the heat pump itself (I’m thinking it is probably the latter)



Seem to have fixed it, I’ve been through all sorts of hoops and it turns out it was just losing the Zigbee signal, regaining it, losing it, regaining it. Each time it was turning the heating on and off. I’ve started it from scratch and it is paired via a bulb and it all seems to be working fine now. When I first paired the thermostat to ZHA that bulb wasn’t present. Relieved to finally have heating!

Was it easy to pair the thermostat in zha?
I’m using hive integration at the moment, but would like to move away from relying on the hive hub and use it through zha instead.

It is, I followed the steps in the link below.

In case that doesn’t work:

  1. Remove the thermostat from the wall and remove a battery
  2. Turn boiler off, then on again
  3. Hold down central heating button on the boiler receiver until light turns pink then release
  4. Hold down the central heating button again until the light turns amber with double flashing
  5. Pair with Home Assistant - I will be using ZHA’s ‘add device’
  6. At this point the amber flash may change to a single flash
  7. Stop ZHA from searching for devices by pressing back
  8. Replace the battery in the thermostat and allow to boot
  9. Press and hold the menu and back buttons, allow the countdown to finish and release when you see welcome - after selecting a language, it will enter pairing mode.
  10. On ZHA select the boiler device you added earlier, now click “ADD DEVICES VIA THIS DEVICE”
  11. The thermostat should now pair to the boiler receiver. The amber light should turn green.

Other than the issue with signal that I’ve just discovered it’s worked a lot better than through the Hive integrations.


Hey - Hoping you might be able to help with an issue I’m having with the SLT3B thermostat.

I decided to move all my Hive stuff to Zigbee local control (using Conbee II Stick) after Hive had an outage recently. I’ve moved all of the TRV’s no problem, full control and response in both directions, all good.

However, I’m having issues with the Thermostat (SLT3B) and receiver (SLT3B) which display incorrect values for the entities like Current temp, target temp etc in HA. There’s no 2 way control i.e. changes made in HA don’t reflect on the thermostat and vica verca.

Not sure on how I can progress form here? If I can’t at least set the target temp of the thermostat via HA then I think I’ll have to move the whole lot back to the Hive Hub :frowning:

TIA - Meldj


Once you paired the state via the Add Device via this device did the stat actually stay homed to the receiver or move within the network?

My stat seems to have homed to a bulb and I see a red light on my receiver quite a bit so clearly losing signal somewhere.