"s6-overlay-suexec: fatal: can only run as pid 1" error when Starting Ring Livestream

I’m using am ameriDroid-N2+ and have successfully setup HomeBridge with the RefreshToken to enable access to the Ring cameras (it works in HomeKit).

When I Start the Ring Livestream add-on, I see s6-overlay-suexec: fatal: can only run as pid 1in the logs.

I have added init: false to the config.yaml for the add-on but still get the same error.

I’ve now reached the limit of my googling ability. Has anyone seen this and got it working?

This one usually occur when a docker container is started with a --init parameter.

According to this article I need to add init: false to the config.yaml : Hello_world example addon from developer docs stopped working (s6 overlay issue?)

I added init: false to the add-on config using the YAML editor.

Have I done this right?


I do not know that solution, so can’t say.
I used the docker commands, since I run HA supervised.

No worries, thanks anyway.

When using the Home Assistant Blue or a similar device, am I adding the init property correctly to the Ring docker add-on?

If not, how do I add the suggested init config?

Bumpy McBumpface

I think you need to edit the docker container itself.

@peakyBlinder did you manage to get a resolution to this ? i am having same issue

I have the same problem. Anyone manage to figure it out.

Same Problem here - any solutions by now?
Where can I find the dockerfile? My /addons and /root/addons is completly empty…

Did you ever get this resolved? I am seeing the same issue.

Same issue. No updates I suppose?

Same issue here. I am running HA Supervised

Home Assistant 2023.5.4
Supervisor 2023.04.1

I have a quick work-around. I cloned the add-on repo locally and fixed the config.json file thusly:

% git diff
diff --git a/ring_hassio/config.json b/ring_hassio/config.json
index 51b075b..7c9243b 100644
--- a/ring_hassio/config.json
+++ b/ring_hassio/config.json
@@ -5,6 +5,7 @@
     "description": "A Home Assistant add-on to enable live streams of Ring Cameras.",
     "url": "https://github.com/jeroenterheerdt/ring-hassio",
     "startup": "application",
+    "init": "false",
     "arch": [

I setup this as a local add-on and installed it. It works now.