Sabnzbd not using config api key

Since 0.88, my sabnzdb is not loading… and I get a persistent notification to configure the API key… is anyone else seeing this?

When I configure the key, it creates a sabnzbd.conf file with the api key in plain text… not what I want…

Is anyone else seeing this? (I have logged an issue on Github)

1 Like

Loaded 0.88.1 and despite entering API key and seeing it stored in a conf file, it’s asking me for the key again?

I’ve had this issue come and go for the last few months. Not sure what the problem is as sometimes it loads the key from my secrets.yaml file, and other times it doesn’t.

I haven’t noticed the sabnzbd.conf file being created, but then again I haven’t looked for it either.

I’d love for this to get sorted.

I’m having the same issue. Each time I start hassio I’m forced to enter the API key even though it’s been specified under the sabnzbd component. The file sabnzbd.conf (which is created if it does not already exist) contains the API Key in json.

  api_key: !secret sabnzbd_apikey
  port: 8080
  name: "sabnzbd"
    - current_status
    - speed
    - queue_size
    - queue_remaining
    - disk_size
    - disk_free
    - queue_count
    - day_size
    - week_size
    - month_size
    - total_size

Any luck with this? I have the same for the past few months, and only today I thought to look for it…

I’ve had this issue for a while, every upgrade pretty much I need to re-add my API key. Has this been raised as an issue in the GitHub repo?

Update: seems it has been raised:

1 Like

I haven’t been ask for an Sabnzbd API key since Hassio v0.103.3. Keeping fingers crossed.

Well, this is still happening to me. Still no solution available?

The only time it happens now is if it can’t connect to SABnzbd, generally if I’ve put that PC to sleep, but then waking it up, I have to manually enter in the api key as it didn’t connect and thinks it’s wrong. Rebooting HA fixes this until it happens again.

I ran into this but the cause was actually my SABnzbd machine which had rebooted and hadn’t started up SABnzbd. A failed API request will prompt for API Key. It could be a timing issue if SABnzbd is starting up along with Hass.

Launched SABnzbd and restarted Hass and it’s all fine.

believe it or not, i’m still suffering the same issue. Repeated calls to enter the api. It’s so annoying.

1 Like