SABnzbd on .70, unable to configure

My SABnzbd is running on a Windows machine, using SSL and configured using my CNAME entry ( My router is setup for port forwarding properly. My HA install is using a Raspberry Pi 3 B+ on using dale3h’s installer script. Configurator detects SABnzbd, but when I paste in my API key for SABnzbd, it says “Failed to register”. I’ve tried manually setting it up as a component in my .yaml file, but with no success. Thoughts?

If I switch SSL off and use the non-SSL port, then the configuration works fine. My current install does not have a valid SSL certificate (just the “Invalid” one that SABnzbd comes with), is this the issue?

To anybody that had this problem as well, I setup a script to copy my SSL cert/private key from my hassio/letsencrypt setup down to my Windows PC running SABnzbd, switched SABnzbd to use this cert/key, restarted SABnzbd, and then re-entered my API key for SABnzbd into Hassio’s Configurator and now it works just fine.

SAB is running on a Windows box for me. I enabled Samba on my Hass box, and then setup a script to copy the PEM/Key files on the Hass box to my SAB machine every hour. Then I updated my SAB configuration to point to the correct copied files.