Sabrent USB 3 SSD Enclosure Pi4 Boot

TLDR; If you are using this sabrent ssd enclosure you might need to tweak a boot file to fix boot from USB 3 and overall speed degradation. Please read through this post You need to add this to the start of /boot/cmdline.txt after finding your product and vendor ID (aaaa:bbbb).


I recently migrated from HassOS to a self managed containerized setup, I did this because I wanted to utilize the new boot from USB and remove the SD card completely. At the time of wiriting this HassOS does not support the new Raspberry Pi 4 boot, from my research it looks to be like a upstream issue with Buildroot and their implementation of U-Boot, though I am not an OS person and only poked around a few days so please correct me. I noticed some random sluggishness and also would hang on boot/fail to boot over USB3. Booting from USB2 was ok, but still sluggish once booted. I would also see this in the boot logs

EXT4-fs error (device /dev/sda2): ext4_find_entry:1463

EDIT: The above info is still valid and will get the device working as a USB mass storage device but does not use the UAS drivers which is needed to achieve full throughput. There is a firmware update for the device that allows the adapter to be used WITHOUT applying the quirks and gives UAS driver support. Sabrent UASP Firmware Update I used this tool via a Windows VM and then removed the quirks from the cmdline.txt file and it booted just fine and then showed UAS drivers

pi at HomeAssistant in ~
➜ lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=uas, 5000M

Thanks - I’ve added a link to this from a new wiki post to collate all the adapters people have tried.

Is this issue only with pi4 or does it apply to pi3. I just did a similar migration to ssd this weekend. Where do I get vendor id from.

I believe it might be Pi4 only, mine was related to USB 3 which Pi3 does not have… And also check the link I posted to the rapsberry Pi forum again, I accidentally copied the wrong link, too many tabs open! You need to comb your dmesg logs to find that info, the post goes through it pretty thoroughly.

Thanks for the quick reply

Had the same issue using

It was only booting using USB 2 for HassOS whilst it was working fine on USB 3 using the official Raspberry pi OS

Managed to find an update tool from another manufacturer using the same JMS583 chipset and now I’m running hassos_rpi4-64-5.2 successfully on SSD via USB 3.0

Never tried the usb-storage.quirks= fix as I managed with the more permanent fix
Time to set it up again

The Sabrent firmware update is not only available for the named SSD enclosure but for a whole set of Sabrent devices, including SATA to USB 3.0 adapter cables. Here they are all listed and shown.

After installing the update my Pi 4 with EEPROM firmware 2020-09-03 finally booted from USB in 4 minutes instead of >30 (!) minutes.
BUT: Boot time and transfer rate over USB 3.0 still are inferior to the same device connected through USB 2.

Boot time USB 2: 1.5 min
Boot time USB 3.0: 3.5 min

Displaying the history of 3 days on USB 2 takes about 15 seconds (many entities and graphs shown).
Displaying the same history on USB 3.0 takes far over a minute.