Samba add-on problem

Hi guys,

I would highly appreciate any help here… I am unable to use the Samba share (it worked for the last 2 years) after update and this makes me crazy…

I am running Home Assistant version 2021.7.4 on a raspi 4.

The SAMBA (version 9.5.1) add-on keeps giving this error:

INTERNAL ERROR: Signal 11: Segmentation fault in pid 374 (4.13.8)
If you are running a recent Samba version, and if you think this problem is not yet fixed in the latest versions, please consider reporting this bug, see
PANIC (pid 374): Signal 11: Segmentation fault in 4.13.8
unable to produce a stack trace on this platform
coredump is handled by helper binary specified at /proc/sys/kernel/core_pattern
check_ntlm_password:  Authentication for user [xxx] -> [xxx] FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1

Are you using anonymous login for SAMBA?

Hi Tom,

Thanks for answering.
No, i simply removed my credentials…

I think I found the problem: you need to get an alias on your network credentials that match the ones in the Samba configuration in the add-on. If it does not find matching credentials, seems it throws these errors out…

I did not manage to make it ask for credentials at login :frowning_face:
Is there any way to do this?

Thanks again

When you map a share on your PC you have the option to define alternative credentials, use this. Otherwise it uses whatever you used to log on to the PC (which probably wont match your SAMBA addon set up).


I’ve solved this issue by adding my Samba credential using Credential Manager on Windows 10:


I have the same issue and tried to credential manager and ensure I am using different credentials when trying to map the drive. I keep seeing NT_STATUS_NO_SUCH_USER in the samba add-on log and it keeps telling me the password doesn’t match. Not sure what I don’t have set correctly in windows. Any advice would be greatly appreciated!