Samba login stopped working

I just migrated from running HA Supervised on Ubuntu to straight HassOS on a NUC. I have restored my previous snapshot and everything is working fine except that I can no longer login to the Samba share from my laptop.

I’ve tried uninstalling / reinstalling the add-on a few times, changed the login user and password but every time I try to login I get told by Windows that there is an issue…

The Samba add-on log says the login tried to use the wrong password, but that’s definitely not correct as I even copy/pasted it from the add-on config to be sure.

Auth: [SMB2,(null)] user [DAVESSURFACEPRO]\[homeassistant] at [Thu, 11 Feb 2021 05:47:46.515166 UTC] with [NTLMv2] status [NT_STATUS_WRONG_PASSWORD] workstation [DAVESSURFACEPRO] remote host [ipv4:] mapped to [DAVESSURFACEPRO]\[homeassistant]. local host [ipv4:] 
{"timestamp": "2021-02-11T05:47:46.515363+0000", "type": "Authentication", "Authentication": {"version": {"major": 1, "minor": 2}, "eventId": 4625, "logonId": "0", "logonType": 3, "status": "NT_STATUS_WRONG_PASSWORD", "localAddress": "ipv4:", "remoteAddress": "ipv4:", "serviceDescription": "SMB2", "authDescription": null, "clientDomain": "DAVESSURFACEPRO", "clientAccount": "homeassistant", "workstation": "DAVESSURFACEPRO", "becameAccount": null, "becameDomain": null, "becameSid": null, "mappedAccount": "homeassistant", "mappedDomain": "DAVESSURFACEPRO", "netlogonComputer": null, "netlogonTrustAccount": null, "netlogonNegotiateFlags": "0x00000000", "netlogonSecureChannelType": 0, "netlogonTrustAccountSid": null, "passwordType": "NTLMv2", "duration": 55017}}

Any tips?

I think this might be a windows update thing. I’ve got multiple issues where it is no longer possible to log on to networked shares. The only PC that is still working has an issue that prevents windows update working…

My laptop is still running Windows 8.1. It worked fine to send the previous snapshot to the fresh HA install (all I did was install HA and then the Samba add-on), it just stopped after the snapshot restoration.

I missed this bit:

Try deleting the mapped drive in windows and re-adding it.

I tried that already, no dice. :man_shrugging:

Just tried again and got this:

To show the IP address is correct:

Strangely I’m also not able to SSH into HA using WinSCP yet Putty works, using the same credentials…

Which SSH addon?

The core one:

I believe its a different setup since you are moving out from linux supervised to a close one which will give you a very little access to your system.

Yeah ok. The Community Addons Web terminal and SSH has a compatibility mode. Might help. Might not.

Samba still works in both cases to access the HA directories. As I had mentioned, it worked fine on a fresh HA (HassOS) install prior to me restoring my snapshot

So without changing any settings I tried to access my HA via Samba again this morning and it worked… I have no explanation.