Samba Not Working ... Windows 10

I am a newbie at this HA stuff, and just trying to follow instructions that appear current. I have reformatted SD starting from scratch a dozen times and have gotten to various levels of success. One time with duckdns/ssl/Samba even working, but then upgraded from 87 to 0.88.0 and could no longer log into HA any more. Rather than bore with sorted details of this past week, I am starting clean once again, with 88.1 on new Pi B+ and 64k SD, and running headless. My router is set to issue fixed IP 192.168.1.127 with 8123 and 3218 port forwarding. I can log in using the hassio.local:8123 or fixed 192.168.1.127:8123. I add/modify Samba config, only changing username/password/interface,then save and start. But hassio file share does not show up on my Windows 10. I try to map network drive to \192.168.1.127\hassio", type in name/password, but fails saying can’t find. On my windows network I have “All Networks” with options set for “turn on sharing to anyone” and “use 128-bit encryption”. I’ve tried rebooting HA, but no change.

Samba Config:
{
“workgroup”: “WORKGROUP”,
“username”: “my name”,
“password”: “my password”,
“interface”: “eth0”,
“allow_hosts”: [
“10.0.0.0/8”,
“172.16.0.0/12”,
“192.168.0.0/16”
]
}

** Samba partial LOG after restart and map network drive attempt :**

added interface eth0 ip=192.168.1.127 bcast=192.168.1.255 netmask=255.255.255.0 INFO: Profiling support unavailable in this build. No builtin backend found, trying to load plugin tdb(/var/lib/samba/registry.tdb): tdb_open_ex: could not open file /var/lib/samba/registry.tdb: No such file or directory daemon_ready: STATUS=daemon ‘smbd’ finished starting up and ready to serve connections waiting for connections Processing section “[config]” Processing section “[addons]” Processing section “[ssl]” Processing section “[share]” Processing section “[backup]” check_ntlm_password: Authentication for user [rarndt] -> [rarndt] FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1 Auth: [SMB2,(null)] user [SYSTEMS][rarndt] at [Fri, 22 Feb 2019 22:53:12.071897 EST] with [NTLMv2] status [NT_STATUS_NO_SUCH_USER] workstation [B4B6863A08F2] remote host [ipv4:192.168.1.7:60341] mapped to [SYSTEMS][rarndt]. local host [ipv4:192.168.1.127:445] Processing section “[config]” Processing section “[addons]” Processing section “[ssl]” Processing section “[share]” Processing section “[backup]” check_ntlm_password: authentication for user [my-name] -> [my-name] -> [my-name] succeeded Failed to fetch record! pcap cache not loaded

I must say, I am quite excited about giving HA a go in replacing my proprietary ADT system with $40 monthly service fee, but I need to get beyond this head bashing some how. Thanks for the help!

Rich

1 Like

Windows may be your problem here. Windows does everything to make it difficult to map any network drive.
Here are some notes from my ordeal of mapping an NAS to my Windows 10 PC.
(Note, I was mapping the guest account on the NAS with no password)

In Network and Sharing Center/ Advanced Sharing Settings:
Home Profile:

  1. Turn On Network Discovery
  2. Turn on file and Printer Sharing
  3. Turn on Public Folder Sharing
    Under File Sharing Connections:
    Enable file sharing with devices that 40- or 56-bit encryption
    Under Homegroup Connections
    I set User Accounts, but I never use Homegroups
    In Windows 10, the computer needs to manage accounts

Under My Computer, Network:
Right click on Network and select “Map Network Drive”
Select the drive letter and enter \Nst-600nu\public.
Login Name: Guest

Next, in “Control Panel”, “All Control Panel Items”, Creditential Manager", click on “Windows Credentials” then the NAS name, then Edit, and enter the same Computername\user, and the password for the NAS.

Works now.

But, I have had other Samba devices that just won’t map in Windows 10 no matter what I try.

For those, I just use the net commands in a batch file.

For example:

net use s: /d
net use s: \192.168.1.29\steve /user:steve MyPassword /persistent:yes

net use z: /d
net use z: \nus2000\z /user:user user /persistent:yes

Also, is there an folder named “hassio” on the Raspberry?

it could also be that smb1 is disabled on your windows 10 machine
by default its now disabled as considered insecure

1 Like

Good catch, I forgot that step.
But Windows doesn’t make it easy to find.
Go to Control Panel, Programs and Features, “Turn Windows Features on or off”. Then select the smb features:

_Win10_smb

3 Likes

Good lord thank you! I’ve never had an issue using Samba on my pi’s and ubuntu linux machines but FINALLY, after reading your little comment here, I was able to get my partner’s stupid Windows 10 puter talking to my HA!
(Gawd I hate Windows)

Although I had Samba working on HA87 a couple weeks ago on my Windows 10, I am not able to duplicate the effort after upgrading to HA88. I have gone through the suggestions here. SMB1 is enable and configured with printer/file/folder sharing and 40-56 bit encryption, but no success with sharing appearing in “>Network” view or finding it through “Map Network Drive”. It does not show up on my Windows 7 either. “net use s: \192.168.1.127\hassio /user:myName myPassword /persistent:yes” just responds “network name cannot be found”.

Thanks for all your help, but I have uninstalled Samba and will move.

I am new to Home Assistant and want to load HACS but it seems the HA File editor will only move one file at a time so I tried to use SAMBA Share but have been unable to get SAMBA to work. I am running a Windows 10 Version 10.0.18362 Build 18362 computer. I am unable to see my Raspberry pi under the Network computers. I have looked at many of the videos explaining various reason SAMBA won’t work properly and have checked them:

  • SMB1.0/CIFS Client is checked
  • Network profile is Private with network discovery and automatic setup checked
  • Function Discovery Resource Publication is set to automatic and running

Looking for suggestions on what to try next.
Bob

Don’t look under network or browse for it. Instead, enter the ip address in the file explorer location bar with two backslashes.

\\192.168.1.5 for example

*do not add :8123

Don’t enable SMB1 or 2. Not worth it.

After doing more research I realized that Samba was never starting. I never got the green dot on the app. More looking around i found a comment that said the password could not be null. Added a password and Samba now starts - green dot and all. Now to see if I can access the files from my windows 10 machine.
I will try the ip address.

Worked!! Thanks, My next step is to load hacs and start work on my Shelly devices. I still have a lot to learn.
Bob

1 Like

HA v .109.6, image on RPI-3
I’m not able to get access to all sub folders. am i missing some thing,?

What subfolders are you referring to? The default shared directories are /addons, /backup, /config, /share, and /ssl

There are no other directories to access.

Where is this documented? I have been futzing with /etc/samba/smb.conf to get my shares to work. No wonder that my share of [backup] would never work… It already existed.

For some reason samba just stopped working on my windows 10 computer. No changes that I am aware of. Map is not connected, can’t remap. Can ping, tacert, no issues.