Samba Share addon

Until last week my samba share worked perfect. But now i cant open my files anymore.

the samba log says:

check_ntlm_password: Authentication for user [GastOpDezePC] -> [GastOpDezePC] FAILED with error NT_STATUS_NO_SUCH_USER
Processing section “[config]”
Processing section “[addons]”
Processing section “[share]”
Processing section "[backup]

How can i open the files again?


Same thing happening to me

Easy fix! You have to setup a password like

“workgroup”: “WORKGROUP”,
“name”: “hassio”,
“guest”: false,
“map”: {
“config”: true,
“addons”: true,
“ssl”: false,
“share”: true,
“backup”: true
“username”: “username123”,
“password”: “pasword123”,
“interface”: “”

1 Like

I’m also having issues with the samba addon since this week.
The initial connection from my win10 machine is taking up about 10 seconds.
After that all seems to work fine.
I’ve tried to setup name+password and having guest enabled/disabled but nothing helps.

I might have fixed it. Setting guest to false, putting in a name and password and rebooting my client seem to have helped.

It’s broken again. I’m giving up.

this actually works! thanks!

Still broken… Is anyone looking to fix this?

Has anyone solved the 10-20 second delay when browsing to the SAMBA share setup on HASSIO? It’s driving me a little crazy :slight_smile:

Have you thought about a better method of doing this?

Syncthing addon, pointing to your config directory, syncthing installed on your machine, and basically sync the config to your machine in nearly real time. Edit on your machine, and it will sync back to hassio

I have the same issue… But my iMac (on the same network) has no trouble connecting to my server though…

My current Samba config is this:

  "workgroup": "WORKGROUP",
  "name": "hassio",
  "guest": false,
  "map": {
    "config": true,
    "addons": true,
    "ssl": false,
    "share": true,
    "backup": true
  "username": "SECRETUSER",
  "password": "SECRETPASS",
  "interface": "eth0",
  "allow_hosts": [

And I’m receiving this error when my Win10 pc tries to connect to the server:

netbios connect: name1=HASSIO         0x20 name2=WINPC        0x0
netbios connect: local=hassio remote=winpc, name type = 0

This is sooo annoying… Did someone find the solution?? :pray:

I have restored samba version 6 from an older backup