Samba Share - Following Links

I would appreciate some help understanding the mechanics of the Samba Share addon.

I have Home Assistant Supervised installed on top of Debian with the Samba Shares addon. I also have a USB hard drive connected to the server with my entire media library. I’d like to access the media library for uploading/downloading/editing from my Windows PC.

I created a symlink (in Debian) in the /usr/share/hassio/media to my hard drive. In Debian I can access the media. However, when accessing the media folder through Windows Explorer, I do not see the linked folder.

I found an smb.conf file in /usr/share/hassio/addons/core/samba/rootfs/etc/samba/ and added the following to the global section:

follow symlinks = yes
wide links = yes
unix extensions = no

Restarted the addon and still no access to the linked folder.

So, what am I missing? Is the smb.conf I modified not the correct file? Did I add the wrong options? Am I just holding it wrong?

The samba file system provides items to be interpreted by the file systems in use.
What you have done would be correct if you were using this under Linux
You are using it under Windows so you would need a ‘shortcut’.
This is further complicated that samba can only follow links under a samba share (not sure if this is also true under cfa) so you need to manually add the external drive under samba too (ie probably a separate share)

It seems that the smb.conf file I’m modifying is not read by Samba Share. I added another share to the file called [entertainment] that just points to an existing folder,.
Entertainment does not show up on my Windows machine when viewing the server through Windows Explorer.

   browseable = yes
   writeable = yes
   path = /media
   valid users = %%USERNAME%%
   force user = root
   force group = root
   veto files = %%VETO_FILES%%
   delete veto files = %%DELETE_VETO_FILES%%

Is there another location of the smb.conf for Samba Share? Is there a setting that tells it to read the new smb.conf file? Other?

Did you find a solution to this. I would also like to expose directories further up the directory tree.

Nope. Couldn’t figure it out and no one provided help, so I gave up. Good luck!