Samsung SmartThings Integration Help

I deleted my SmartThings Integration and am trying to get it running again. after removing I followed the advice found online and executed an API string to remove all apps from SmartThings, then I try to reinstall the integration. It starts off fine, I add my key when prompted, choose the location “My Home” then when it opens a new window and shows me “{“requestId”:“c38a256e-1f70-ea9f-b131-545854860cb5”,“error”:{“code”:“UnexpectedError”,“message”:“A non-recoverable error condition occurred.”,“details”:[]}}

The url for the above message is -
**" ".

Not sure where to go from here. I’ve tried deleting my SmartThings account completely as well as running it from a fresh install of HomeAssistant.

1 Like

I’m getting exactly the same. I’ve sent a tweet to Smartthings but as yet no reply. My link was working fine until about a week ago and all the devices were saying ‘offline’ so I tried same as you - remove the integration and try to relink it. But yeah, I’m at same point as you. It certainly looks like an error with Samsung Smartthings API.

I’ve tried so many things… have you found and deleted the apps via API command?

curl --header "Authorization: Bearer <SECRET KEY>" | python -m json.tool

curl -X DELETE --header "Authorization: Bearer <SECRET KEY>"<appID>

I also deleted the SmartThings file in the hidden directory, config/.storage/

I deleted my entire Samsung account @


anything you’ve done that I didn’t try?


Blimey! You’ve gone a lot further than I have so far! I’m just trying a database delete… Tried incognito mode for setup, clearing cookies etc. Very strange. Maybe others in the community could delete their smartthings and reinstate to see if they get an error too?

Remove &theme=smartthings from the url and press enter then it works.
I had the same and did find a topic with this sollution


You sir, are a genius! Thank you!

That is awesome… such a simple fix. Wonder why that’s happening. Thanks for your help!